[PATCH v4 09/11] drm/ci: rockchip: Refactor existing rockchip jobs

Vignesh Raman vignesh.raman at collabora.com
Fri Mar 15 04:18:23 PDT 2024


Hi Helen,

On 07/03/24 19:32, Helen Koike wrote:
> 
> 
> On 06/03/2024 00:06, Vignesh Raman wrote:
>> For rockchip rk3288 and rk3399, the display driver is rockchip.
>> Currently, in drm-ci for rockchip, only the display driver is
>> tested. Refactor the existing rockchip jobs so that gpu driver
>> testing jobs can be added later and update xfails accordingly.
>>
>> Signed-off-by: Vignesh Raman <vignesh.raman at collabora.com>
>> ---
>>
>> v2:
>>    - Refactor the patch to rename job to indicate display driver testing,
>>      rename the existing xfail files.
>>
>> v3:
>>    - Add the job name in GPU_VERSION and use it for xfail file names
>>      instead of using DRIVER_NAME. Also update xfails.
>>
>> v4:
>>    - Remove the display suffix in job and rename xfails accordingly.
>>      Remove the change adding job name in GPU_VERSION.
>>
>> ---
>>   drivers/gpu/drm/ci/test.yml                   | 36 ++++++++----
>>   .../drm/ci/xfails/rockchip-rk3288-fails.txt   | 58 ++++++-------------
>>   .../drm/ci/xfails/rockchip-rk3288-flakes.txt  | 20 +++++++
>>   .../drm/ci/xfails/rockchip-rk3288-skips.txt   | 54 ++---------------
>>   .../drm/ci/xfails/rockchip-rk3399-fails.txt   | 38 ++++++------
>>   .../drm/ci/xfails/rockchip-rk3399-flakes.txt  | 28 +++++++--
>>   .../drm/ci/xfails/rockchip-rk3399-skips.txt   |  5 +-
>>   7 files changed, 110 insertions(+), 129 deletions(-)
>>   create mode 100644 drivers/gpu/drm/ci/xfails/rockchip-rk3288-flakes.txt
>>
>> diff --git a/drivers/gpu/drm/ci/test.yml b/drivers/gpu/drm/ci/test.yml
>> index 6ae6398b3d88..831e580e6dfd 100644
>> --- a/drivers/gpu/drm/ci/test.yml
>> +++ b/drivers/gpu/drm/ci/test.yml
>> @@ -153,33 +153,45 @@ msm:sdm845:
>>     script:
>>       - ./install/bare-metal/cros-servo.sh
>> -rockchip:rk3288:
>> -  extends:
>> -    - .lava-igt:arm32
>> +.rockchip:
>>     stage: rockchip
>>     variables:
>> -    DRIVER_NAME: rockchip
> 
> Looks like it make sense to keep DRIVER_NAME here, no?
> 
>> -    DEVICE_TYPE: rk3288-veyron-jaq
>>       DTB: ${DEVICE_TYPE}
>>       BOOT_METHOD: depthcharge
>> +
>> +.rk3288:
>> +  extends:
>> +    - .lava-igt:arm32
>> +    - .rockchip
> 
> Maybe, instead of extending .rockchip here, make .rockchip tied to the 
> DRIVER_NAME and .rk3288 tied to the GPU_VERSION, and on rockchip:rk3288 
> you can extend both .rockchip and .rk3288, what do you think?
> So rockchip:rk3399 you can extend .rockchip and .rk3399.
> 
> and in the panfrost one you can have a .panfrost (that can extend 
> .rockchip if they are the same definition).
> 
> I feel it becomes less confusing, what do you think?
> 
> I would even add some prefix or suffix to make it less confusing, like 
> .driver-rockchip and .gpu-rk3288 for instance, making it a bit more 
> intuitive and helping our future selves :)

Thanks for the suggestion. This can be done. Should we do it only
for rockchip jobs or others also (meson, mediatek) ?

> 
>> +  variables:
>> +    DEVICE_TYPE: rk3288-veyron-jaq
>>       KERNEL_IMAGE_TYPE: "zimage"
>> -    GPU_VERSION: rk3288
> 
> Looks like it make sense to keep GPU_VERSION here, no? Same comment for 
> .rk3399.
Yes, will fix this.

Regards,
Vignesh



More information about the Linux-mediatek mailing list