[PATCH v5 5/9] drm/mediatek: dsi: Replace open-coded instance of HZ_PER_MHZ

CK Hu (胡俊光) ck.hu at mediatek.com
Wed Feb 14 23:40:11 PST 2024


Hi, Angelo:

On Wed, 2024-02-07 at 15:53 +0100, AngeloGioacchino Del Regno wrote:
> In mtk_dsi_phy_timconfig(), we're dividing the `data_rate` variable,
> expressed in Hz to retrieve a value in MHz: instead of open-coding,
> use the HZ_PER_MHZ definition, available in linux/units.h.

Reviewed-by: CK Hu <ck.hu at mediatek.com>

> 
> Reviewed-by: Alexandre Mergnat <amergnat at baylibre.com>
> Signed-off-by: AngeloGioacchino Del Regno <
> angelogioacchino.delregno at collabora.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_dsi.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_dsi.c
> b/drivers/gpu/drm/mediatek/mtk_dsi.c
> index a330bb94c44a..52758cab0abf 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dsi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dsi.c
> @@ -13,6 +13,7 @@
>  #include <linux/phy/phy.h>
>  #include <linux/platform_device.h>
>  #include <linux/reset.h>
> +#include <linux/units.h>
>  
>  #include <video/mipi_display.h>
>  #include <video/videomode.h>
> @@ -238,7 +239,7 @@ static void mtk_dsi_mask(struct mtk_dsi *dsi, u32
> offset, u32 mask, u32 data)
>  static void mtk_dsi_phy_timconfig(struct mtk_dsi *dsi)
>  {
>  	u32 timcon0, timcon1, timcon2, timcon3;
> -	u32 data_rate_mhz = DIV_ROUND_UP(dsi->data_rate, 1000000);
> +	u32 data_rate_mhz = DIV_ROUND_UP(dsi->data_rate, HZ_PER_MHZ);
>  	struct mtk_phy_timing *timing = &dsi->phy_timing;
>  
>  	timing->lpx = (60 * data_rate_mhz / (8 * 1000)) + 1;


More information about the Linux-mediatek mailing list