[PATCH v5 06/10] drm/ci: meson: Refactor existing meson jobs

Helen Koike helen.koike at collabora.com
Mon Apr 1 09:42:40 PDT 2024



On 01/04/2024 03:12, Vignesh Raman wrote:
> For Amlogic Meson SOC the display driver is meson. Currently,
> in drm-ci for meson, only the display driver is tested.
> Refactor the existing meson jobs so that gpu driver testing
> jobs can be added later and update xfails accordingly.
> 
> Signed-off-by: Vignesh Raman <vignesh.raman at collabora.com>
> ---
> 
> v2:
>    - Refactor the patch to rename job to indicate display driver testing,
>      rename the existing xfail files.
> 
> v3:
>    - Add the job name in GPU_VERSION and use it for xfail file names instead
>      of using DRIVER_NAME.
> 
> v4:
>    - Remove the display suffix in job and rename xfails accordingly.
>      Remove the change adding job name in GPU_VERSION.
> 
> v5:
>    - Add meson-display job.
> 
> ---
>   drivers/gpu/drm/ci/test.yml                    | 14 +++++++++++---
>   drivers/gpu/drm/ci/xfails/meson-g12b-fails.txt |  5 -----
>   2 files changed, 11 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/gpu/drm/ci/test.yml b/drivers/gpu/drm/ci/test.yml
> index adeb05bdb440..505733069995 100644
> --- a/drivers/gpu/drm/ci/test.yml
> +++ b/drivers/gpu/drm/ci/test.yml
> @@ -357,14 +357,17 @@ panfrost:mt8183:
>   .meson:

I also would rename this to .meson-device, so we don't confuse with the 
driver name, what do you think?

With or without this change:

Acked-by: Helen Koike <helen.koike at collabora.com>

Thanks
Helen

>     extends:
>       - .lava-igt:arm64
> -  stage: meson
>     variables:
> -    DRIVER_NAME: meson
>       DTB: ${DEVICE_TYPE}
>       BOOT_METHOD: u-boot
>       KERNEL_IMAGE_TYPE: "image"
>   
> -meson:g12b:
> +.meson-display:
> +  stage: meson
> +  variables:
> +    DRIVER_NAME: meson
> +
> +.g12b:
>     extends:
>       - .meson
>     parallel: 3
> @@ -373,6 +376,11 @@ meson:g12b:
>       GPU_VERSION: g12b
>       RUNNER_TAG: mesa-ci-x86-64-lava-meson-g12b-a311d-khadas-vim3
>   
> +meson:g12b:
> +  extends:
> +    - .g12b
> +    - .meson-display
> +
>   virtio_gpu:none:
>     stage: virtio-gpu
>     variables:
> diff --git a/drivers/gpu/drm/ci/xfails/meson-g12b-fails.txt b/drivers/gpu/drm/ci/xfails/meson-g12b-fails.txt
> index 56a2ae7047b4..029b4ade21f6 100644
> --- a/drivers/gpu/drm/ci/xfails/meson-g12b-fails.txt
> +++ b/drivers/gpu/drm/ci/xfails/meson-g12b-fails.txt
> @@ -5,11 +5,6 @@ kms_cursor_legacy at single-bo,Fail
>   kms_cursor_legacy at single-move,Fail
>   kms_cursor_legacy at torture-bo,Fail
>   kms_cursor_legacy at torture-move,Fail
> -kms_force_connector_basic at force-edid,Fail
> -kms_hdmi_inject at inject-4k,Fail
> -kms_plane_cursor at overlay,Fail
> -kms_plane_cursor at primary,Fail
> -kms_plane_cursor at viewport,Fail
>   kms_properties at connector-properties-atomic,Fail
>   kms_properties at connector-properties-legacy,Fail
>   kms_properties at get_properties-sanity-atomic,Fail



More information about the Linux-mediatek mailing list