[PATCH V2 03/12] clk: mediatek: reset: Refine functions of set_clr
Rex-BC Chen
rex-bc.chen at mediatek.com
Thu Apr 21 22:00:38 PDT 2022
On Thu, 2022-04-21 at 11:07 +0200, AngeloGioacchino Del Regno wrote:
> Il 20/04/22 15:05, Rex-BC Chen ha scritto:
> > To make driver more readable, revise functions of set_clr.
> > - Add to_rst_data().
> > - Extract common code within assert and deassert to
> > mtk_reset_update_set_clr().
> >
> > Signed-off-by: Rex-BC Chen <rex-bc.chen at mediatek.com>
> > ---
> > drivers/clk/mediatek/reset.c | 32 +++++++++++++++++++++--------
> > ---
> > 1 file changed, 21 insertions(+), 11 deletions(-)
> >
> > diff --git a/drivers/clk/mediatek/reset.c
> > b/drivers/clk/mediatek/reset.c
> > index 9110d0b4229f..6574b19daf0f 100644
> > --- a/drivers/clk/mediatek/reset.c
> > +++ b/drivers/clk/mediatek/reset.c
> > @@ -20,26 +20,36 @@ struct mtk_reset {
> > struct reset_controller_dev rcdev;
> > };
> >
> > -static int mtk_reset_assert_set_clr(struct reset_controller_dev
> > *rcdev,
> > - unsigned long id)
> > +static inline struct mtk_reset *to_rst_data(struct
> > reset_controller_dev *rcdev)
>
> to_mtk_reset() looks more consistent, as many developers are using
> the naming
> "to_{struct_name}".
Hello Angelo,
ok, I will fix this in next version.
>
> Also, can you please mention the indentation fixes in the commit
> description?
>
I add another refinement patch in next version.
BRs,
Rex
> Thanks,
> Angelo
>
More information about the Linux-mediatek
mailing list