[PATCH v2 1/3] watchdog: mtk_wdt: Refactor code to support more SoCs
Guenter Roeck
linux at roeck-us.net
Mon May 10 06:21:54 PDT 2021
On 5/9/21 2:17 PM, Boris Lysov wrote:
> This patch makes some constants SoC-dependent to support more watchdogs
> in the future. It adds shifts of WDT_MODE_KEY and SWSYSRST_KEY to
> mtk_wdt_data struct. This is done to bring support for various Mediatek
> watchdogs which use same register structure but slightly different field
> offsets in the UNLOCK_KEY registers. For example, mt6577 watchdog has
> WDT_MODE_KEY and SWSYSRST_KEY at [15:8] instead of currently (and only)
> supported [31:24].
> Moreover, this patch adds SWSYSRST_KEY value to mtk_wdt_data because this
> value also depends on specific SoC watchdog, for example mt6577 uses 0x15
> instead of 0x88.
>
> Signed-off-by: Boris Lysov <arzamas-16 at mail.ee>
> ---
> drivers/watchdog/mtk_wdt.c | 76 ++++++++++++++++++++++++++++----------
> 1 file changed, 57 insertions(+), 19 deletions(-)
>
> diff --git a/drivers/watchdog/mtk_wdt.c b/drivers/watchdog/mtk_wdt.c
> index 97ca993bd009..9d3091b12c06 100644
> --- a/drivers/watchdog/mtk_wdt.c
> +++ b/drivers/watchdog/mtk_wdt.c
> @@ -44,13 +44,27 @@
> #define WDT_MODE_IRQ_EN (1 << 3)
> #define WDT_MODE_AUTO_START (1 << 4)
> #define WDT_MODE_DUAL_EN (1 << 6)
> -#define WDT_MODE_KEY 0x22000000
> +#define WDT_MODE_KEY 0x22
>
> #define WDT_SWRST 0x14
> #define WDT_SWRST_KEY 0x1209
> -
> #define WDT_SWSYSRST 0x18U
> -#define WDT_SWSYS_RST_KEY 0x88000000
> +
> +#define MT2712_WDT_MODE_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT2712_SWSYSRST_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT2712_SWSYSRST_KEY 0x88
> +
> +#define MT6589_WDT_MODE_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT6589_SWSYSRST_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT6589_SWSYSRST_KEY 0x88
> +
> +#define MT8183_WDT_MODE_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT8183_SWSYSRST_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT8183_SWSYSRST_KEY 0x88
> +
> +#define MT8192_WDT_MODE_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT8192_SWSYSRST_KEY_SHIFT 24 // unlock_key [31:24]
> +#define MT8192_SWSYSRST_KEY 0x88
>
> #define DRV_NAME "mtk-wdt"
> #define DRV_VERSION "1.0"
> @@ -60,6 +74,7 @@ static unsigned int timeout;
>
> struct mtk_wdt_dev {
> struct watchdog_device wdt_dev;
> + const struct mtk_wdt_data *data;
> void __iomem *wdt_base;
> spinlock_t lock; /* protects WDT_SWSYSRST reg */
> struct reset_controller_dev rcdev;
> @@ -67,18 +82,37 @@ struct mtk_wdt_dev {
>
> struct mtk_wdt_data {
> int toprgu_sw_rst_num;
> + u8 wdt_mode_key_shift;
> + u8 wdt_swsys_rst_key;
> + u8 wdt_swsys_rst_key_shift;
> };
>
> static const struct mtk_wdt_data mt2712_data = {
> - .toprgu_sw_rst_num = MT2712_TOPRGU_SW_RST_NUM,
> + .toprgu_sw_rst_num = MT2712_TOPRGU_SW_RST_NUM,
> + .wdt_mode_key_shift = MT2712_WDT_MODE_KEY_SHIFT,
> + .wdt_swsys_rst_key_shift = MT2712_SWSYSRST_KEY_SHIFT,
> + .wdt_swsys_rst_key = MT2712_SWSYSRST_KEY,
> +};
> +
> +static const struct mtk_wdt_data mt6589_data = {
> + .toprgu_sw_rst_num = -1,
> + .wdt_mode_key_shift = MT6589_WDT_MODE_KEY_SHIFT,
> + .wdt_swsys_rst_key_shift = MT6589_SWSYSRST_KEY_SHIFT,
> + .wdt_swsys_rst_key = MT6589_SWSYSRST_KEY,
> };
>
> static const struct mtk_wdt_data mt8183_data = {
> - .toprgu_sw_rst_num = MT8183_TOPRGU_SW_RST_NUM,
> + .toprgu_sw_rst_num = MT8183_TOPRGU_SW_RST_NUM,
> + .wdt_mode_key_shift = MT8183_WDT_MODE_KEY_SHIFT,
> + .wdt_swsys_rst_key_shift = MT8183_SWSYSRST_KEY_SHIFT,
> + .wdt_swsys_rst_key = MT8183_SWSYSRST_KEY,
> };
>
> static const struct mtk_wdt_data mt8192_data = {
> - .toprgu_sw_rst_num = MT8192_TOPRGU_SW_RST_NUM,
> + .toprgu_sw_rst_num = MT8192_TOPRGU_SW_RST_NUM,
> + .wdt_mode_key_shift = MT8192_WDT_MODE_KEY_SHIFT,
> + .wdt_swsys_rst_key_shift = MT8192_SWSYSRST_KEY_SHIFT,
> + .wdt_swsys_rst_key = MT8192_SWSYSRST_KEY,
> };
>
> static int toprgu_reset_update(struct reset_controller_dev *rcdev,
> @@ -86,20 +120,20 @@ static int toprgu_reset_update(struct reset_controller_dev *rcdev,
> {
> unsigned int tmp;
> unsigned long flags;
> - struct mtk_wdt_dev *data =
> + struct mtk_wdt_dev *wdev =
Please do not rename variables. If you dislike that the name matches the name
of the newly introduced structure element, find a different name for that.
Thanks,
Guenter
More information about the Linux-mediatek
mailing list