Aw: Re: BUG: devm_regulator_get returns EPROBE_DEFER (5.3-rc5..next-20190822) for bpi-r2/mt7623/mt7530

Frank Wunderlich frank-w at public-files.de
Thu Aug 22 13:28:44 PDT 2019


cfba5de9b99f drivers: Introduce device lookup variants by of_node

this looks suspicios to me since the change is in the function which fails:

struct regulator_dev *of_find_regulator_by_node(struct device_node *np)
 {
        struct device *dev;
 
-       dev = class_find_device(&regulator_class, NULL, np, of_node_match);
+       dev = class_find_device_by_of_node(&regulator_class, np);


but i cannot revert this commit so i did it manually...but this does not seem to be the cause...still error 517, also a change in core.c is not the cause...

how can i check instantiation at runtime?

regards Frank


> Gesendet: Donnerstag, 22. August 2019 um 21:30 Uhr
> Von: "Mark Brown" <broonie at kernel.org>
> An: "Frank Wunderlich" <frank-w at public-files.de>
> Cc: "Liam Girdwood" <lgirdwood at gmail.com>, linux-kernel at vger.kernel.org, linux-mediatek at lists.infradead.org, "René van Dorst" <opensource at vdorst.com>
> Betreff: Re: BUG: devm_regulator_get returns EPROBE_DEFER (5.3-rc5..next-20190822) for bpi-r2/mt7623/mt7530
>
> On Thu, Aug 22, 2019 at 09:23:57PM +0200, Frank Wunderlich wrote:
> 
> > seems of_find_regulator_by_node(node); is failing here, but i see the dts-node (mt6323_vpa_reg: buck_vpa) in /sys/firmware/devicetree/...
> 
> It's not looking for the node in the device tree, it's looking
> for that regulator to instantiate at runtime.  Is that happening?
>



More information about the Linux-mediatek mailing list