[PATCH v2 9/9] soc: mediatek: pwrap: fixup warnings from coding style

Yingjoe Chen yingjoe.chen at mediatek.com
Tue Jul 18 09:26:34 PDT 2017


[Resend due to bad mail format, sorry about the noise if you got two]


On Tue, 2017-07-18 at 17:49 +0800, sean.wang at mediatek.com wrote:
> From: Sean Wang <sean.wang at mediatek.com>
> 
> fixup those warnings such as lines over 80 words and parenthesis
> alignment which would be complained by checkpatch.pl.
> 
> Signed-off-by: Sean Wang <sean.wang at mediatek.com>
> ---
>  drivers/soc/mediatek/mtk-pmic-wrap.c | 20 +++++++++++++-------
>  1 file changed, 13 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/soc/mediatek/mtk-pmic-wrap.c b/drivers/soc/mediatek/mtk-pmic-wrap.c
> index 142f40a..5f1036f 100644
> --- a/drivers/soc/mediatek/mtk-pmic-wrap.c
> +++ b/drivers/soc/mediatek/mtk-pmic-wrap.c
> @@ -1057,7 +1057,8 @@ static int pwrap_init_cipher(struct pmic_wrapper *wrp)
>  	/* wait for cipher data ready at PMIC */
>  	ret = pwrap_wait_for_state(wrp, pwrap_is_pmic_cipher_ready);
>  	if (ret) {
> -		dev_err(wrp->dev, "timeout waiting for cipher data ready at PMIC\n");
> +		dev_err(wrp->dev,
> +			"timeout waiting for cipher data ready at PMIC\n");

Sean,

I think the old code is easier to read. When the line is only slightly
over the 80 chars limit, some maintainers will even ask to keep it in
one line to make it easier to read.

So if it is OK with Matthias, I think we should just keep it as is.

Joe.C





More information about the Linux-mediatek mailing list