[PATCH 0/4] dma: use designated initializers for acpi_device_id
Pawel Zalewski
pzalewski at thegoodpenguin.co.uk
Fri Sep 4 07:10:39 PDT 2026
This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to make use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]
The plan is to convert acpi_device_id::driver_data to have an anonymous
union, similarly to what was introduced for PCI and I2C device ID tables.
The goal is to increase type-safety (as most of the existing casts are gone),
to improve readability and to make use intent a bit more clear:
```
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
```
But for that to work all lists containing the structs need to use named
initializers first to avoid triggering -Wmissing-braces. I already have
patches that implement this and touching a lot of kernel subsystmes that
use the acpi_device_id struct and that list keeps on growing. Therefore,
I have decided to split the series per every subsystem into:
- pre-clean-ups that convert the lists to use named initializers (this series)
- actual implementations that make some of the modules use the new driver_data_ptr
That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.
Tested builds on x86-64 and a64 in Yocto using 7.3-rc1.
[1] https://lore.kernel.org/all/cover.1780048925.git.u.kleine-koenig@baylibre.com/
Signed-off-by: Pawel Zalewski <pzalewski at thegoodpenguin.co.uk>
---
Pawel Zalewski (4):
dma: dw: use designated initializers for acpi_device_id
dma: loongson: use named initializers for acpi_device_id
dma: qcom: use named initializers for acpi_device_id
dma: xgene-dmac: use named initializers for acpi_device_id
drivers/dma/dw/platform.c | 12 ++++++------
drivers/dma/loongson/loongson2-apb-cmc-dma.c | 4 ++--
drivers/dma/qcom/hidma.c | 8 ++++----
drivers/dma/xgene-dma.c | 4 ++--
4 files changed, 14 insertions(+), 14 deletions(-)
---
base-commit: bc35965f6940a9bf834d54187b6088b8eb09206d
change-id: 20260904-acpi-dma-ee1add4bae4e
Best regards,
--
Pawel Zalewski <pzalewski at thegoodpenguin.co.uk>
More information about the linux-arm-kernel
mailing list