[PATCH 03/11] pwm: rcar: Use FIELD_PREP() for PWMCR_CC0 access
Geert Uytterhoeven
geert+renesas at glider.be
Mon Oct 26 07:55:19 PDT 2026
Use the FIELD_PREP() helper instead of open-coding the same operation.
Drop the now unused RCAR_PWMCR_CC0_SHIFT definition, and redefine
RCAR_PWMCR_CC0_SHIFT using GENMASK() while at it.
Signed-off-by: Geert Uytterhoeven <geert+renesas at glider.be>
---
drivers/pwm/pwm-rcar.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/pwm/pwm-rcar.c b/drivers/pwm/pwm-rcar.c
index 1733cd700693713e..4641f258df531baf 100644
--- a/drivers/pwm/pwm-rcar.c
+++ b/drivers/pwm/pwm-rcar.c
@@ -25,8 +25,7 @@
#define RCAR_PWM_MAX_CYCLE 1023
#define RCAR_PWMCR 0x00
-#define RCAR_PWMCR_CC0_MASK 0x000f0000
-#define RCAR_PWMCR_CC0_SHIFT 16
+#define RCAR_PWMCR_CC0_MASK GENMASK(19, 16)
#define RCAR_PWMCR_CCMD BIT(15)
#define RCAR_PWMCR_SYNC BIT(11)
#define RCAR_PWMCR_SS0 BIT(4)
@@ -99,7 +98,7 @@ static void rcar_pwm_set_clock_control(struct rcar_pwm_chip *rp,
div >>= 1;
- value |= div << RCAR_PWMCR_CC0_SHIFT;
+ value |= FIELD_PREP(RCAR_PWMCR_CC0_MASK, div);
rcar_pwm_write(rp, value, RCAR_PWMCR);
}
--
2.43.0
More information about the linux-arm-kernel
mailing list