[RFC PATCH v2 06/10] arm_mpam: resctrl: Rename struct mpam_resctrl_dom to mpam_resctrl_ctrl_dom

Jinjie Ruan ruanjinjie at huawei.com
Mon Oct 26 05:40:07 PDT 2026



在 2026/10/20 6:07, Reinette Chatre 写道:
> struct mpam_resctrl_dom holds the control domain of a resource, while
> its monitoring domain is held by struct mpam_resctrl_mon_dom. Unlike the
> name of the monitoring structure, the name struct mpam_resctrl_dom does
> not say which kind of domain the structure holds.
> 
> Rename it to struct mpam_resctrl_ctrl_dom to match its monitoring
> counterpart.
> 
> No functional change.

LGTM
Reviewed-by: Jinjie Ruan <ruanjinjie at huawei.com>

> 
> Signed-off-by: Reinette Chatre <reinette.chatre at intel.com>
> ---
>  drivers/resctrl/mpam_internal.h |  2 +-
>  drivers/resctrl/mpam_resctrl.c  | 18 +++++++++---------
>  2 files changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/resctrl/mpam_internal.h b/drivers/resctrl/mpam_internal.h
> index 1df439ecb055..dc304e4e0dc0 100644
> --- a/drivers/resctrl/mpam_internal.h
> +++ b/drivers/resctrl/mpam_internal.h
> @@ -432,7 +432,7 @@ struct mpam_msc_ris {
>  	struct mpam_garbage	garbage;
>  };
>  
> -struct mpam_resctrl_dom {
> +struct mpam_resctrl_ctrl_dom {
>  	struct mpam_component		*ctrl_comp;
>  	struct rdt_ctrl_domain		resctrl_ctrl_dom;
>  };
> diff --git a/drivers/resctrl/mpam_resctrl.c b/drivers/resctrl/mpam_resctrl.c
> index ce5519635c51..022920be1862 100644
> --- a/drivers/resctrl/mpam_resctrl.c
> +++ b/drivers/resctrl/mpam_resctrl.c
> @@ -1375,7 +1375,7 @@ u32 resctrl_arch_get_config(struct rdt_resource *r, struct rdt_ctrl_domain *d,
>  	struct mpam_config *cfg;
>  	struct mpam_props *cprops;
>  	struct mpam_resctrl_res *res;
> -	struct mpam_resctrl_dom *dom;
> +	struct mpam_resctrl_ctrl_dom *dom;
>  	enum mpam_device_features configured_by;
>  
>  	lockdep_assert_cpus_held();
> @@ -1384,7 +1384,7 @@ u32 resctrl_arch_get_config(struct rdt_resource *r, struct rdt_ctrl_domain *d,
>  		return resctrl_get_default_ctrl(r);
>  
>  	res = container_of(r, struct mpam_resctrl_res, resctrl_res);
> -	dom = container_of(d, struct mpam_resctrl_dom, resctrl_ctrl_dom);
> +	dom = container_of(d, struct mpam_resctrl_ctrl_dom, resctrl_ctrl_dom);
>  	cprops = &res->class->props;
>  
>  	/*
> @@ -1435,7 +1435,7 @@ int resctrl_arch_update_one(struct rdt_resource *r, struct rdt_ctrl_domain *d,
>  	struct mpam_config cfg;
>  	struct mpam_props *cprops;
>  	struct mpam_resctrl_res *res;
> -	struct mpam_resctrl_dom *dom;
> +	struct mpam_resctrl_ctrl_dom *dom;
>  
>  	lockdep_assert_cpus_held();
>  	lockdep_assert_irqs_enabled();
> @@ -1448,7 +1448,7 @@ int resctrl_arch_update_one(struct rdt_resource *r, struct rdt_ctrl_domain *d,
>  	 * resctrl_arch_update_domains() relies on this.
>  	 */
>  	res = container_of(r, struct mpam_resctrl_res, resctrl_res);
> -	dom = container_of(d, struct mpam_resctrl_dom, resctrl_ctrl_dom);
> +	dom = container_of(d, struct mpam_resctrl_ctrl_dom, resctrl_ctrl_dom);
>  	cprops = &res->class->props;
>  
>  	if (mpam_resctrl_hide_cdp(r->rid))
> @@ -1618,7 +1618,7 @@ static struct mpam_component *find_component(struct mpam_class *class, int cpu)
>  static int mpam_resctrl_setup_ctrl_domain(unsigned int cpu,
>  					  struct rdt_resource *r,
>  					  struct mpam_component *comp,
> -					  struct mpam_resctrl_dom *dom)
> +					  struct mpam_resctrl_ctrl_dom *dom)
>  {
>  	struct rdt_ctrl_domain *ctrl_d = &dom->resctrl_ctrl_dom;
>  	int err;
> @@ -1710,10 +1710,10 @@ static struct mpam_resctrl_mon_dom *mpam_resctrl_get_mon_domain_from_cpu(int cpu
>  	return NULL;
>  }
>  
> -static struct mpam_resctrl_dom *
> +static struct mpam_resctrl_ctrl_dom *
>  mpam_resctrl_get_ctrl_domain_from_cpu(int cpu, struct mpam_resctrl_res *res)
>  {
> -	struct mpam_resctrl_dom *dom;
> +	struct mpam_resctrl_ctrl_dom *dom;
>  	struct rdt_resource *r = &res->resctrl_res;
>  
>  	lockdep_assert_cpus_held();
> @@ -1730,7 +1730,7 @@ static void mpam_resctrl_add_cpu_ctrl_domain(unsigned int cpu,
>  					     struct mpam_resctrl_res *res)
>  {
>  	struct rdt_resource *r = &res->resctrl_res;
> -	struct mpam_resctrl_dom *dom;
> +	struct mpam_resctrl_ctrl_dom *dom;
>  	struct mpam_component *comp;
>  
>  	lockdep_assert_held(&domain_list_lock);
> @@ -1780,7 +1780,7 @@ static void mpam_resctrl_remove_cpu_ctrl_domain(unsigned int cpu,
>  						struct mpam_resctrl_res *res)
>  {
>  	struct rdt_resource *r = &res->resctrl_res;
> -	struct mpam_resctrl_dom *dom;
> +	struct mpam_resctrl_ctrl_dom *dom;
>  
>  	lockdep_assert_held(&domain_list_lock);
>  

-- 
Best regards,
Jinjie




More information about the linux-arm-kernel mailing list