[PATCH v16 14/16] barrier: add tests for smp_cond_load_*_timeout()

bot+bpf-ci at kernel.org bot+bpf-ci at kernel.org
Fri Oct 16 00:55:38 PDT 2026


> barrier: add tests for smp_cond_load_*_timeout()

TL;DR: Nit only, in the KUnit test patch: the suite name
"smp-cond-load-*-timeout" and file name barrier-timeout-test.c may not follow
KUnit naming conventions (underscores, _kunit.c suffix).

> diff --git a/lib/tests/barrier-timeout-test.c b/lib/tests/barrier-timeout-test.c
> new file mode 100644
> index 000000000000..9c12cd36e7d2
> --- /dev/null
> +++ b/lib/tests/barrier-timeout-test.c
> @@ -0,0 +1,129 @@

[ ... ]

> +static struct kunit_suite barrier_timeout_test_suite = {
> +	.name = "smp-cond-load-*-timeout",
> +	.test_cases = barrier_timeout_test_cases,
> +};

this isn't a bug, but would a different suite name fit the KUnit naming
conventions better?

Documentation/dev-tools/kunit/style.rst asks for underscores rather than
dashes in suite names, and for the test file to be named
tests/<suite>_kunit.c.  The current name "smp-cond-load-*-timeout" uses
dashes and a literal '*', and the file is barrier-timeout-test.c.

Would something like smp_cond_load_timeout (with the file named
lib/tests/barrier_timeout_kunit.c or similar) work instead?


---
AI reviewed your patch. Please fix the bug or email reply why it's not a bug.
See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md

CI run summary: https://github.com/kernel-patches/bpf/actions/runs/38867477666


More information about the linux-arm-kernel mailing list