[PATCH 00/13] PCI: brcmstb: Stop using chip numbers for conditions

Manivannan Sadhasivam manivannan.sadhasivam at oss.qualcomm.com
Wed Oct 14 00:40:52 PDT 2026


On 2026-09-11 19:35 -0400, Jim Quinlan wrote:
> Much of the brcmstb PCIe driver code does (essentially) this:
> 
>         if (pcie->chip == 0x1234 || pcie->chip == 0x5678) {
>                 /* ... */
>         }
> 
> when it should instead do this:
> 
>         if (behavior_xyz(pcie)) {
>                 /* ... */
>         }
> 
> This series does the above.  In addition, some other minor improvements are
> added in the hopes of making the code more readable.
> 

Thanks for doing this! Those checks were quite ugly.

> Jim Quinlan (13):
>   PCI: brcmstb: Remove redundant const specifier for struct fields
>   PCI: brcmstb: Use flags u32 instead of bools
>   PCI: brcmstb: Add Broadcom quirks macro
>   PCI: brcmstb: Declare and assign quirk OB_WIN_32BIT_ADDR
>   PCI: brcmstb: Declare and assign quirk OB_WIN_MAXSZ_128MB
>   PCI: brcmstb: Declare and assign flag IS_BMIPS
>   PCI: brcmstb: Declare and assign quirk 32BIT_PCI_OPS
>   PCI: brcmstb: Declare and assign quirk NO_RGR1_TIMER
>   PCI: brcmstb: Declare and assign quirk EARLY_PERST_ASSERT
>   PCI: brcmstb: Declare and assign quirk PERST_PCIE_REV_CUTOFF

I'll apply the first 10 patches as I see some comment from Florian on patch 10
and Sashiko's comment on patch 11. You can send a follow up series addressing
those comments.

- Mani




More information about the linux-arm-kernel mailing list