[PATCH 1/2] i2c: i2c-core-acpi: use named initializers for acpi_device_id
Thierry Reding
thierry.reding at kernel.org
Tue Oct 13 08:48:58 PDT 2026
On Fri, Sep 18, 2026 at 02:01:50PM +0100, Pawel Zalewski wrote:
> Use a designated initializer for the acpi_device_id fields which makes the
> code more readable and consistent with how lists are initialized in the
> rest of the kernel code base. Also drop explicitly setting fields to 0
> where it is redundant.
>
> Unify the list terminator to have a single space between the brackets and
> no trailing comma.
>
> Signed-off-by: Pawel Zalewski <pzalewski at thegoodpenguin.co.uk>
> ---
> drivers/i2c/i2c-core-acpi.c | 14 +++++++-------
> 1 file changed, 7 insertions(+), 7 deletions(-)
Reviewed-by: Thierry Reding <treding at nvidia.com>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20261013/ba10baf0/attachment-0001.sig>
More information about the linux-arm-kernel
mailing list