[PATCH v3 0/4] dmaengine: use designated initializers for acpi_device_id
Vinod Koul
vkoul at kernel.org
Mon Oct 5 08:43:24 PDT 2026
On Wed, 16 Sep 2026 16:27:53 +0100, Pawel Zalewski wrote:
> This series is converting lists that contain the acpi_device_id struct,
> which is defined in the include/linux/device-id/acpi.h to make use of named
> initializers (which they do not use currently). This work is part of the on
> going effort in the kernel associated with device-ids [1]
>
> The plan is to convert acpi_device_id::driver_data to have an anonymous
> union, similarly to what was introduced for PCI and I2C device ID tables.
> The goal is to increase type-safety (most of the existing casts are gone),
> to improve readability and to make use intent a bit more clear:
>
> [...]
Applied, thanks!
[1/4] dmaengine: dw: use designated initializers for acpi_device_id
commit: 3a03a5866e82027c0fa96f6208721397e5a6ff78
[2/4] dmaengine: loongson: use named initializers for acpi_device_id
commit: b37c93bc1cfd0f5fb898b7943bd0c1797341a41d
[3/4] dmaengine: qcom: use named initializers for acpi_device_id
commit: db09763394959442d91d86840717412073c41abc
[4/4] dmaengine: xgene-dma: use named initializers for acpi_device_id
commit: b2c203a5878b0d3f95e4802fa01e320d317b82cf
Best regards,
--
~Vinod
More information about the linux-arm-kernel
mailing list