[PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently
patchwork-bot+linux-riscv at kernel.org
patchwork-bot+linux-riscv at kernel.org
Sun Nov 1 14:16:03 PST 2026
Hello:
This series was applied to riscv/linux.git (fixes)
by Hans Verkuil <hverkuil+cisco at kernel.org>:
On Fri, 11 Sep 2026 03:27:08 +0000 you wrote:
> This series removes the implicit assumption that RISC-V supports exactly
> eight IPI message types.
>
> Currently, the SBI, CLINT and ACLINT SSWI IPI providers use
> BITS_PER_BYTE when sizing the generic IPI mux, while IMSIC carries a
> separate IMSIC_NR_IPI definition set to 8. These values happen to match
> IPI_MAX today, but neither is the proper source of truth for the number
> of RISC-V IPI message types.
>
> [...]
Here is the summary with links:
- [v2,1/6] riscv: smp: Move enum ipi_message_type to asm/smp.h
https://git.kernel.org/riscv/c/1ae91dc397eb
- [v2,2/6] riscv: sbi: Use IPI_MAX for SBI IPI muxing
https://git.kernel.org/riscv/c/2a0d49514f29
- [v2,3/6] clocksource: clint: Use IPI_MAX for IPI muxing
https://git.kernel.org/riscv/c/f6326e26f602
- [v2,4/6] irqchip/aclint-sswi: Use IPI_MAX for IPI muxing
https://git.kernel.org/riscv/c/a89546503a0e
- [v2,5/6] irqchip/imsic: Use IPI_MAX instead of IMSIC_NR_IPI
https://git.kernel.org/riscv/c/5b104000160d
- [v2,6/6] media: mtk-vpu: rename IPI_MAX to IPI_VPU_MAX
https://git.kernel.org/riscv/c/d1d2645e755b
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
More information about the linux-arm-kernel
mailing list