[PATCH 09/27] gpio: rockchip: Add RK3572 GPIO support
Cunhao Lu
1579567540 at qq.com
Sun Nov 1 03:31:33 PST 2026
Hi,
>> pending = readl_relaxed(bank->reg_base + bank->gpio_regs->int_status);
>
> Please sprinkle in some newlines for readability here...
>
>> + for (unsigned int i = 0; i < bank->nr_irqs; i++) {
>> + if (bank->irqs[i] == irq_desc_get_irq(desc)) {
>> + pending &= bank->irq_masks[i];
>> + break;
>> + }
>> + }
>
> ... here ...
>
>> for_each_set_bit(irq, &pending, 32) {
>> ...
>> + assigned |= bank->irq_masks[i];
>> + }
>
> ... here, etc.
>
>> + bank->irq_masks[0] = ~assigned;
I will add blank lines at these places to improve readability in the
next version.
>> diff --git a/include/soc/rockchip/rockchip_sip.h b/include/soc/rockchip/rockchip_sip.h
>
> The changes in headers in other subsystems should be in separate patches.
I am already working on splitting the patches by subsystem, and I will
put these header changes into separate patches. I will resubmit the GPIO
part later with these changes addressed.
Thank you for taking the time to review my patch!
Best regards,
Cunhao Lu
More information about the linux-arm-kernel
mailing list