[PATCH v4 4/8] riscv/runtime-const: Replace open-coded placeholder with RUNTIME_MAGIC
Charlie Jenkins
thecharlesjenkins at gmail.com
Mon Jun 22 22:24:56 PDT 2026
On Thu, 30 Apr 2026 09:47:26 +0000, K Prateek Nayak <kprateek.nayak at amd.com> wrote:
> Define the placeholder used for lui + addi[w] patching sequence as
> RUNTIME_MAGIC and use that instead of open coding the constants in the
> inline assembly.
>
> No functional changes intended.
>
> Suggested-by: Guo Ren <guoren at kernel.org>
> Signed-off-by: K Prateek Nayak <kprateek.nayak at amd.com>
This is a great addition, thank you!
Reviewed-by: Charlie Jenkins <thecharlesjenkins at gmail.com>
Tested-by: Charlie Jenkins <thecharlesjenkins at gmail.com>
--
Charlie Jenkins <thecharlesjenkins at gmail.com>
More information about the linux-arm-kernel
mailing list