[PATCH v7 5/7] KVM: arm64: Validate the offset to the mem access descriptor

Sebastian Ene sebastianene at google.com
Mon Jun 22 04:22:31 PDT 2026


On Mon, Jun 22, 2026 at 09:23:26AM +0000, Sebastian Ene wrote:
> On Thu, Jun 18, 2026 at 05:56:24PM +0100, Vincent Donnefort wrote:
> > On Wed, Jun 17, 2026 at 02:51:28PM +0000, Sebastian Ene wrote:
> > > Prevent the pKVM hypervisor from making assumptions that the
> > > endpoint memory access descriptor (EMAD) comes right after the
> > > FF-A memory region header.
> > > Prior to FF-A version 1.1 the header of the memory region
> > > didn't contain an offset to the endpoint memory access descriptor.
> > > The layout of a memory transaction looks like this from 1.1 onward:
> > > Type | Field name | Offset
> > > [ Header | ffa_mem_region  | 0
> > >   EMAD 1 | ffa_mem_region_attributes) | ffa_mem_region.ep_mem_offset
> > > ]
> > > Verify that the offset to the first endpoint memory access descriptor
> > > is within the mailbox buffer bounds.
> > > 
> > > Also, fix one hardcoded sizeof(struct ffa_mem_region_attributes) that
> > > should be replaced ffa_emad_size_get() for compatibility with FFA v1.0.
> > > 
> > > Fixes: 42fb33dde42b ("KVM: arm64: Use FF-A 1.1 with pKVM")
> > > Signed-off-by: Sebastian Ene <sebastianene at google.com>
> > > Signed-off-by: Mostafa Saleh <smostafa at google.com>
> > > ---
> > >  arch/arm64/kvm/hyp/nvhe/ffa.c | 29 +++++++++++++++++++++--------
> > >  1 file changed, 21 insertions(+), 8 deletions(-)
> > > 
> > > diff --git a/arch/arm64/kvm/hyp/nvhe/ffa.c b/arch/arm64/kvm/hyp/nvhe/ffa.c
> > > index 2d211661952e..1a2abd0154c6 100644
> > > --- a/arch/arm64/kvm/hyp/nvhe/ffa.c
> > > +++ b/arch/arm64/kvm/hyp/nvhe/ffa.c
> > > @@ -476,11 +476,14 @@ static void __do_ffa_mem_xfer(const u64 func_id,
> > >  	DECLARE_REG(u32, fraglen, ctxt, 2);
> > >  	DECLARE_REG(u64, addr_mbz, ctxt, 3);
> > >  	DECLARE_REG(u32, npages_mbz, ctxt, 4);
> > > +	u32 offset, nr_ranges, checked_offset, em_mem_access_off;
> > >  	struct ffa_mem_region_attributes *ep_mem_access;
> > >  	struct ffa_composite_mem_region *reg;
> > >  	struct ffa_mem_region *buf;
> > > -	u32 offset, nr_ranges, checked_offset;
> > >  	int ret = 0;
> > > +	size_t mem_region_len = !FFA_MEM_REGION_HAS_EP_MEM_OFFSET(hyp_ffa_version) ?
> > > +		offsetof(struct ffa_mem_region, ep_mem_offset) :
> > > +		sizeof(struct ffa_mem_region);


While talking with Vincent about this change, we agreed that it would be
easier to introduce a helper that will get the size of the struct
ffa_mem_region which is different based on the ff-a version.

This would hopefully increase the readability of this. The description
of the struct ffa_mem_region can be found in (Table 5.19: Lend, donate or
share memory transaction descriptor) from DEN0077A.

I will spin a new version to address this and collect the review tags.

> > >  
> > >  	if (addr_mbz || npages_mbz || fraglen > len ||
> > >  	    fraglen > KVM_FFA_MBOX_NR_PAGES * PAGE_SIZE) {
> > > @@ -488,8 +491,7 @@ static void __do_ffa_mem_xfer(const u64 func_id,
> > >  		goto out;
> > >  	}
> > >  
> > > -	if (fraglen < sizeof(struct ffa_mem_region) +
> > > -		      sizeof(struct ffa_mem_region_attributes)) {
> > > +	if (fraglen < mem_region_len + ffa_emad_size_get(hyp_ffa_version)) {
> > 
> > Can't we replace mem_region_len with ffa_mem_desc_offset()? that pretty much
> > looks like the same thing.
> > 
> 
> We can't because `ffa_mem_desc_offset` dereferences struct
> ffa_mem_region to extract ep_mem_offset as per the latest updates. 
> 
> > 
> > >  		ret = FFA_RET_INVALID_PARAMETERS;
> > >  		goto out;
> > >  	}
> > > @@ -508,8 +510,13 @@ static void __do_ffa_mem_xfer(const u64 func_id,
> > >  	buf = hyp_buffers.tx;
> > >  	memcpy(buf, host_buffers.tx, fraglen);
> > >  
> > > -	ep_mem_access = (void *)buf +
> > > -			ffa_mem_desc_offset(buf, 0, hyp_ffa_version);
> > > +	em_mem_access_off = ffa_mem_desc_offset(buf, 0, hyp_ffa_version);
> > > +	if ((u64)em_mem_access_off + ffa_emad_size_get(hyp_ffa_version) > fraglen) {
> > 
> > This check looks like ffa_mem_desc_offset() with count to 1.
> > 
> >
> > > +		ret = FFA_RET_INVALID_PARAMETERS;
> > > +		goto out_unlock;
> > > +	}
> > > +
> > > +	ep_mem_access = (void *)buf + em_mem_access_off;
> > >  	offset = ep_mem_access->composite_off;
> > >  	if (!offset || buf->ep_count != 1 || buf->sender_id != HOST_FFA_ID) {
> > >  		ret = FFA_RET_INVALID_PARAMETERS;
> > > @@ -574,9 +581,9 @@ static void do_ffa_mem_reclaim(struct arm_smccc_1_2_regs *res,
> > >  	DECLARE_REG(u32, handle_lo, ctxt, 1);
> > >  	DECLARE_REG(u32, handle_hi, ctxt, 2);
> > >  	DECLARE_REG(u32, flags, ctxt, 3);
> > > +	u32 offset, len, fraglen, fragoff, em_mem_access_off;
> > >  	struct ffa_mem_region_attributes *ep_mem_access;
> > >  	struct ffa_composite_mem_region *reg;
> > > -	u32 offset, len, fraglen, fragoff;
> > >  	struct ffa_mem_region *buf;
> > >  	int ret = 0;
> > >  	u64 handle;
> > > @@ -599,8 +606,14 @@ static void do_ffa_mem_reclaim(struct arm_smccc_1_2_regs *res,
> > >  	len = res->a1;
> > >  	fraglen = res->a2;
> > >  
> > > -	ep_mem_access = (void *)buf +
> > > -			ffa_mem_desc_offset(buf, 0, hyp_ffa_version);
> > > +	em_mem_access_off = ffa_mem_desc_offset(buf, 0, hyp_ffa_version);
> > > +	if ((u64)em_mem_access_off + ffa_emad_size_get(hyp_ffa_version) > fraglen) {
> > 
> > ditto. ffa_mem_desc_offset()
> > 
> > > +		ret = FFA_RET_INVALID_PARAMETERS;
> > > +		ffa_rx_release(res);
> > > +		goto out_unlock;
> > > +	}
> > > +
> > > +	ep_mem_access = (void *)buf + em_mem_access_off;
> > >  	offset = ep_mem_access->composite_off;
> > >  	/*
> > >  	 * We can trust the SPMD to get this right, but let's at least
> > > -- 
> > > 2.54.0.1136.gdb2ca164c4-goog
> > > 
> 
> Thanks,
> Sebastian



More information about the linux-arm-kernel mailing list