[PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array

Sven Peter sven at kernel.org
Sun Jul 19 06:15:31 PDT 2026



On 7/18/26 19:25, Uwe Kleine-König (The Capable Hub) wrote:
> Initializing a struct using list initializers is hard to read, compared
> to that using named initializers is more ideomatic. Convert the macro
> used to assign values in the driver's pci_device_id array accordingly.
>
> This change doesn't introduce any changes to the compiled array on an
> x86 and an arm64 build.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig at baylibre.com>
> ---

Acked-by: Sven Peter <sven at kernel.org>


Best,


Sven



More information about the linux-arm-kernel mailing list