[PATCH v4 13/27] KVM: s390: Prepare KVM/s390 for a second KVM module

Christian Borntraeger borntraeger at linux.ibm.com
Fri Jul 10 02:22:29 PDT 2026



Am 06.07.26 um 10:52 schrieb Steffen Eiden:
> Lay the groundwork for a second KVM module. Guard KVM/s390 behind the
> KVM_S390 config and turn CONFIG_KVM on if selected. Move all the
> kvm_host definitions to _s390 postfixed headers. Prepare local header
> include guards for a new location. Move gamp related tracing into a
> separate file. While at it, rename the main KVM/s390 files from
> s390-kvm.{c,h} to just s390.{c,h} to match the naming scheme of other
> architectures.
> 
> No functional change.

[...]
>   arch/s390/include/asm/kvm_host.h              | 774 +-----------------
>   .../asm/{kvm_host.h => kvm_host_s390.h}       |   6 +-
>   arch/s390/include/asm/kvm_host_types.h        | 347 +-------
[...]
>   copy arch/s390/include/asm/{kvm_host.h => kvm_host_s390.h} (99%)
>   copy arch/s390/include/asm/{kvm_host_types.h => kvm_host_s390_types.h} (98%)
This is just an "almost" rename only in the end. Maybe we can convince git to show a better diffstat to reflect that?

In any case, I guess we can handle patch 13 and patch 14 pretty soon upfront so that the patch series gets smaller and is easier to review.



More information about the linux-arm-kernel mailing list