[PATCH 05/42] drm/mediatek: Rename all display component type to have DISP_ prefix
CK Hu (胡俊光)
ck.hu at mediatek.com
Thu Jul 2 23:25:01 PDT 2026
On Wed, 2026-07-01 at 14:20 +0200, AngeloGioacchino Del Regno wrote:
> The mtk_ddp_comp_type enumeration will end up containing both the
> Display Controller and Media Data Path Controller components: this
> is because those can be interconnected together (as in, using MDP
> components in Display Controller paths is possible!) and because
> both MMSYS and MuteX are managing both of those in practically the
> same way.
>
> Rename all of the Display Controller related HW components in the
> list to always have a "DISP_" prefix.
> This includes components that are in the MDP Controller instead,
> and the strategy here is for some of those to also have the same
> DISP_ prefix, so that:
> - Display Controller specific components have a DISP_ prefix
> - Example: MTK_DISP_(NAME)
> - MDP Controller components that can be interconnected to the
> Display Controller will have both DISP_ and MDP_ prefixes
> - Example: MTK_DISP_MDP_(NAME)
> - MDP Controller components that are exclusive to MDP and can
> not be interconnected with Display Controller will only have
> an MDP_ prefix but not a DISP_ prefix
> - Example: MTK_MDP_(NAME).
Reviewed-by: CK Hu <ck.hu at mediatek.com>
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
> ---
More information about the linux-arm-kernel
mailing list