[PATCH v9 36/38] phy: rockchip: usbdp: Rename phy_needs_reinit to orientation_changed
Sebastian Reichel
sebastian.reichel at collabora.com
Wed Jul 1 16:36:14 PDT 2026
phy_needs_reinit used to signal mode or cable orientation changes,
but mode changes are now tracked separately. Thus it makes sense
to rename the variable to show what it actually signals.
Signed-off-by: Sebastian Reichel <sebastian.reichel at collabora.com>
---
drivers/phy/rockchip/phy-rockchip-usbdp.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/phy/rockchip/phy-rockchip-usbdp.c b/drivers/phy/rockchip/phy-rockchip-usbdp.c
index 51aac07ef9fe..735ce1bfac7a 100644
--- a/drivers/phy/rockchip/phy-rockchip-usbdp.c
+++ b/drivers/phy/rockchip/phy-rockchip-usbdp.c
@@ -174,7 +174,7 @@ struct rk_udphy {
/* PHY status management */
bool flip;
- bool phy_needs_reinit;
+ bool orientation_changed;
u8 hw_mode; /* modes currently supported by hardware */
u8 sw_mode; /* modes currently requested */
u8 status; /* current PHY power state */
@@ -667,7 +667,7 @@ static int rk_udphy_orien_sw_set(struct typec_switch_dev *sw,
if (udphy->flip != flipped) {
dev_dbg(udphy->dev, "cable orientation changed, PHY re-init required.\n");
- udphy->phy_needs_reinit = true;
+ udphy->orientation_changed = true;
}
udphy->flip = flipped;
@@ -1020,7 +1020,7 @@ static int rk_udphy_update_power_state(struct rk_udphy *udphy)
u8 target_mode = udphy->hw_mode & udphy->sw_mode;
int ret;
- if (!udphy->phy_needs_reinit && udphy->status == target_mode)
+ if (!udphy->orientation_changed && udphy->status == target_mode)
return 0;
/*
@@ -1067,7 +1067,7 @@ static int rk_udphy_update_power_state(struct rk_udphy *udphy)
phy_notify_reset(udphy->phy_u3, PHY_NOTIFY_POST_RESET);
udphy->status = target_mode;
- udphy->phy_needs_reinit = false;
+ udphy->orientation_changed = false;
return 0;
}
--
2.53.0
More information about the linux-arm-kernel
mailing list