[PATCH 2/2] dmaengine: add union chan_dev for dma_chan::dev for clarity

Logan Gunthorpe logang at deltatee.com
Thu Aug 13 10:33:22 PDT 2026



On 2026-08-12 3:24 p.m., Frank.Li at oss.nxp.com wrote:
> From: Frank Li <Frank.Li at nxp.com>
> 
> The current dma_chan structure contains both "device" and "dev". So
> 
> chan->device->dev refers to the DMA engine device.
> chan->dev->device refers to the per-channel device instance.
> 
> Their similar naming makes the distinction unclear and increases reader
> confusion.
> 
> Add union dma_chan::chan_dev to make its purpose explicit and clearly
> identify it as the per-channel device. After all user switch to chan_dev,
> union and dma_chan::dev will be removed.
> 
> Update the kernel-doc accordingly. Besides its sysfs usage, the per-channel
> device is also used by some DMA engine drivers for IOMMU mapping and
> therefore deserves a more accurate description.
> 
> No functional change intended.
> 
> Signed-off-by: Frank Li <Frank.Li at nxp.com>

Thanks, I've often been confused by this myself. I'm glad you're
cleaning it up and making progress.

Reviewed-by: Logan Gunthorpe <logang at deltatee.com>



More information about the linux-arm-kernel mailing list