[PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name
Logan Gunthorpe
logang at deltatee.com
Thu Aug 13 10:28:43 PDT 2026
On 2026-08-12 3:24 p.m., Frank.Li at oss.nxp.com wrote:
> From: Frank Li <Frank.Li at nxp.com>
>
> Use the existing dma_chan_name() helper to obtain the per-channel device
> name instead of open-coding: dev_name(chan->dev->device) /
> dev_name(chan2dev())
>
> Simplify the code and improve consistency.
>
> No functional change intended.
>
> Signed-off-by: Frank Li <Frank.Li at nxp.com>
Makes sense to me.
Reviewed-by: Logan Gunthorpe <logang at deltatee.com>
More information about the linux-arm-kernel
mailing list