[PATCH] arm64: topology: fix arch_cpu_idle_enter()

Sean Wang1 seanwang1 at lenovo.com
Mon Aug 10 01:02:23 PDT 2026


On Mon, Aug 10, 2026 at 02:26PM, Beata Michalska wrote:
>
> That actually changes semantics here. This path is strictly AMU-oriented and
> topology_scale_freq_tick is a dispatcher that does not really care about the
> actual source of the scale info. So it would be best if this could verify whether
> AMUs are the current source and call a tick only then, bailing out otherwise.

You're right. Using topology_scale_freq_tick() here would incorrectly invoke a non-AMU source's callback if one has been registered after AMU was cleared.

I'll add a helper topology_scale_freq_source() to check whether AMU is the current source.

I will send v2 with this approach.



More information about the linux-arm-kernel mailing list