[PATCH] pinctrl: Use IRQ trigger mask helpers
Linus Walleij
linusw at kernel.org
Thu Aug 6 14:41:24 PDT 2026
On Sun, Aug 2, 2026 at 4:06 PM Maulik Shah <maulik.shah at oss.qualcomm.com> wrote:
> Use IRQ_TYPE_LEVEL_MASK and IRQ_TYPE_EDGE_BOTH instead of open-coded
> trigger type combinations in irqchip callbacks.
>
> No functional change intended.
>
> Assisted-by: Claude:claude-sonnet-5
> Signed-off-by: Maulik Shah <maulik.shah at oss.qualcomm.com>
Nice cleanup, patch applied!
Yours,
Linus Walleij
More information about the linux-arm-kernel
mailing list