[PATCH v4 5/6] arm64: cpufeature: Rename BBML2_NOABORT as BBML3

Will Deacon will at kernel.org
Thu Aug 6 10:11:32 PDT 2026


On Thu, Jul 23, 2026 at 10:10:32AM +0530, Linu Cherian wrote:
> - As bbml2_noabort is functionally equivalent to bbml3,
>   rename cpu/system_supports_bbml2_noabort to
>   cpu/system_supports_bbml3.
>   The ARM64 capability name is also renamed accordingly.
> 
> - As BBML2_NOABORT or the equivalent BBML3 is the
>   kernel requirement for setting up linear map with
>   block/contpte mappings and not BBML2, replace all
>   bbml2 references with bbml3.
> 
> FEAT_BBML3, is introduced as part of 2025 Architecture Extensions.
> https://developer.arm.com/documentation/109697/2026_03/2025-Architecture-Extensions
> 
> No functional changes are introduced with this patch.
> 
> Reviewed-by: Gavin Shan <gshan at redhat.com>
> Reviewed-by: Anshuman Khandual <anshuman.khandual at arm.com>
> Signed-off-by: Linu Cherian <linu.cherian at arm.com>
> ---
>  arch/arm64/include/asm/cpufeature.h |  6 ++--
>  arch/arm64/kernel/cpufeature.c      | 30 +++++-----------
>  arch/arm64/mm/contpte.c             | 21 +++++------
>  arch/arm64/mm/mmu.c                 | 54 ++++++++++++++---------------
>  arch/arm64/mm/proc.S                |  4 +--
>  arch/arm64/tools/cpucaps            |  2 +-
>  6 files changed, 50 insertions(+), 67 deletions(-)

This breaks the build because you haven't updated the caller in the SMMUv3
SVA code.

I'll push a fix on top...

Will



More information about the linux-arm-kernel mailing list