[PATCH v4 3/3] iio: adc: bcm_iproc_adc: Convert probe error handling to dev_err_probe()

Markus Elfring Markus.Elfring at web.de
Mon Aug 3 06:01:18 PDT 2026


> This simplifies the probe error handling by replacing open-coded
> dev_err() and return sequences while preserving the existing
> messages.

See also once more:
* https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v7.2-rc6#n94

* https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v7.2-rc6#n669


Regards,
Markus



More information about the linux-arm-kernel mailing list