[PATCH 08/34] mfd: sec: fix open parenthesis alignment (of_property_read_bool)
Krzysztof Kozlowski
krzk at kernel.org
Thu Mar 27 09:55:06 PDT 2025
On 26/03/2025 10:21, André Draszik wrote:
> On Wed, 2025-03-26 at 08:06 +0100, Krzysztof Kozlowski wrote:
>> On 23/03/2025 23:39, André Draszik wrote:
>>> As a preparation for adding support for Samsung's S2MPG10, which is
>>> connected via SPEEDY / ACPM rather than I2C, we're going to split out
>>> (move) all I2C-specific driver code into its own kernel module, and
>>> create a (common) core transport-agnostic kernel module.
>>>
>>> That move of code would highlight some unexpected alignment which
>>> checkpatch would complain about. To avoid that, address the error now,
>>> before the split, to keep the amount of unrelated changes to a minimum
>>> when actually doing the split.
>>>
>>> Signed-off-by: André Draszik <andre.draszik at linaro.org>
>>> ---
>>> drivers/mfd/sec-core.c | 10 ++++++----
>>> 1 file changed, 6 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/drivers/mfd/sec-core.c b/drivers/mfd/sec-core.c
>>> index 83693686567df61b5e09f7129dc6b01d69156ff3..b931f66f366571d93ce59c301265fe1c9550b37d 100644
>>> --- a/drivers/mfd/sec-core.c
>>> +++ b/drivers/mfd/sec-core.c
>>> @@ -276,10 +276,12 @@ sec_pmic_i2c_parse_dt_pdata(struct device *dev)
>>> if (!pd)
>>> return ERR_PTR(-ENOMEM);
>>>
>>> - pd->manual_poweroff = of_property_read_bool(dev->of_node,
>>> - "samsung,s2mps11-acokb-ground");
>>> - pd->disable_wrstbi = of_property_read_bool(dev->of_node,
>>> - "samsung,s2mps11-wrstbi-ground");
>>> + pd->manual_poweroff =
>>> + of_property_read_bool(dev->of_node,
>>> + "samsung,s2mps11-acokb-ground");
>>
>> I don't think this code more readable. The continued line should be
>> re-aligned.
>
> Agree, but I've tried to stay below 80 columns. I'll just move the string to
> the right in the next version so it is aligned with the '(' (but becomes a
> longer line).
Lee expressed in the past that he is happy with 100. Coding style
accepts longer lines.
Best regards,
Krzysztof
More information about the linux-arm-kernel
mailing list