[PATCH v12 05/13] PCI: dwc: Add dw_pcie_parent_bus_offset()
Bjorn Helgaas
helgaas at kernel.org
Mon Mar 24 11:28:27 PDT 2025
On Mon, Mar 24, 2025 at 10:48:23PM +0530, Manivannan Sadhasivam wrote:
> On Sat, Mar 15, 2025 at 03:15:40PM -0500, Bjorn Helgaas wrote:
> > From: Frank Li <Frank.Li at nxp.com>
> >
> > Return the offset from CPU physical address to the parent bus address of
> > the specified element of the devicetree 'reg' property.
> > +resource_size_t dw_pcie_parent_bus_offset(struct dw_pcie *pci,
> > + const char *reg_name,
> > + resource_size_t cpu_phy_addr)
> > +{
>
> s/cpu_phy_addr/cpu_phys_addr/g
Fixed, thanks!
> > + struct device *dev = pci->dev;
> > + struct device_node *np = dev->of_node;
> > + int index;
> > + u64 reg_addr;
> > +
> > + /* Look up reg_name address on parent bus */
>
> 'parent bus' is not accurate as the below code checks for the 'reg_name' in
> current PCI controller node.
We want the address of "reg_name" on the node's primary side. We've
been calling that the "parent bus address", I guess because it's the
address on the "parent bus" of the node.
I'm not sure what the best term is for this. Do you have a
suggestion?
If "parent bus address" is the wrong term, maybe we need to rename
dw_pcie_parent_bus_offset() itself?
Currently we pass in cpu_phys_addr, but this function doesn't need it
except for the debug code added later. I would really rather have
something like this in the callers:
pci->parent_bus_offset = pp->cfg0_base -
dw_pcie_parent_bus_addr(pci, "config");
because then the offset is computed sort of at the same level where
it's used, and a grep for "cfg0_base" would find both the set and the
use and they would be easy to match up.
> > + index = of_property_match_string(np, "reg-names", reg_name);
> > +
> > + if (index < 0) {
> > + dev_err(dev, "No %s in devicetree \"reg\" property\n", reg_name);
>
> Both of these callers are checking for the existence of the
> 'reg_name' property before calling this API. So this check seems to
> be redundant (for now).
True, but I don't see a way to enforce the caller checks. I don't
like the idea of calling of_property_read_reg(np, index, ...) where we
have to look the caller to verify that "index" is valid.
Bjorn
More information about the linux-arm-kernel
mailing list