[PATCH v7 4/5] Add debugfs based error injection support in DWC

Shradha Todi shradha.t at samsung.com
Tue Mar 4 09:00:58 PST 2025



> -----Original Message-----
> From: Krzysztof Wilczyński <kw at linux.com>
> Sent: 04 March 2025 21:05
> To: Manivannan Sadhasivam <manivannan.sadhasivam at linaro.org>
> Cc: Shradha Todi <shradha.t at samsung.com>; linux-kernel at vger.kernel.org; linux-pci at vger.kernel.org; linux-arm-
> kernel at lists.infradead.org; linux-perf-users at vger.kernel.org; lpieralisi at kernel.org; robh at kernel.org; bhelgaas at google.com;
> jingoohan1 at gmail.com; Jonathan.Cameron at huawei.com; fan.ni at samsung.com; nifan.cxl at gmail.com;
> a.manzanares at samsung.com; pankaj.dubey at samsung.com; cassel at kernel.org; 18255117159 at 163.com;
> xueshuai at linux.alibaba.com; renyu.zj at linux.alibaba.com; will at kernel.org; mark.rutland at arm.com
> Subject: Re: [PATCH v7 4/5] Add debugfs based error injection support in DWC
> 
> Hello,
> 
> [....]
> > > > +		29) Generates duplicate TLPs - duplicate_dllp
> > > > +		30) Generates Nullified TLPs - nullified_tlp
> > >
> > > Would the above field called "duplicate_dllp" for duplicate TLPs be
> > > a potential typo?  Perhaps this should be called "duplicate_tlp"?
> > >
> >
> > Looks like a typo. As per Synopsys documentation, there is only 'duplicate TLP'
> > field.
> >
> > Good catch!
> 
> Updated.  Thank you!
> 

Sorry, this was a typo. Krzysztof, we need another change for this typo.

diff --git a/drivers/pci/controller/dwc/pcie-designware-debugfs.c b/drivers/pci/controller/dwc/pcie-designware-debugfs.c
index 729ac14ff700..4d77db3ca6ae 100644
--- a/drivers/pci/controller/dwc/pcie-designware-debugfs.c
+++ b/drivers/pci/controller/dwc/pcie-designware-debugfs.c
@@ -113,7 +113,7 @@ static const struct dwc_pcie_err_inj err_inj_list[] = {
        {"posted_tlp_data", 0x4, 0x4},
        {"non_post_tlp_data", 0x4, 0x5},
        {"cmpl_tlp_data", 0x4, 0x6},
-       {"duplicate_dllp", 0x5, 0x0},
+       {"duplicate_tlp", 0x5, 0x0},
        {"nullified_tlp", 0x5, 0x1},
 };

So sorry for the inconvenience! Should I post a patch for this?

> 	Krzysztof





More information about the linux-arm-kernel mailing list