[PATCH] arm64/mm: Rename pte_mkpresent() as pte_mkvalid()
Will Deacon
will at kernel.org
Wed Jan 8 08:38:50 PST 2025
On Tue, 07 Jan 2025 08:00:16 +0530, Anshuman Khandual wrote:
> pte_present() is no longer synonymous with pte_valid() as it also tests for
> pte_present_invalid() as well. Hence pte_mkpresent() is misleading, because
> all that does is make an entry mapped, via setting PTE_VALID. Hence rename
> the helper as pte_mkvalid() which reflects its functionality appropriately.
>
>
Applied to arm64 (for-next/mm), thanks!
[1/1] arm64/mm: Rename pte_mkpresent() as pte_mkvalid()
https://git.kernel.org/arm64/c/169226583097
Cheers,
--
Will
https://fixes.arm64.dev
https://next.arm64.dev
https://will.arm64.dev
More information about the linux-arm-kernel
mailing list