[PATCH v4 14/14] iommu/arm-smmu-v3: Report events that belong to devices attached to vIOMMU
Nicolin Chen
nicolinc at nvidia.com
Mon Jan 6 10:46:13 PST 2025
On Mon, Jan 06, 2025 at 11:01:32AM +0800, Baolu Lu wrote:
> On 1/4/25 03:43, Nicolin Chen wrote:
> > diff --git a/include/uapi/linux/iommufd.h b/include/uapi/linux/iommufd.h
> > index 0a08aa82e7cc..55e3d5a14cca 100644
> > --- a/include/uapi/linux/iommufd.h
> > +++ b/include/uapi/linux/iommufd.h
> > @@ -1016,9 +1016,24 @@ struct iommu_ioas_change_process {
> > /**
> > * enum iommu_veventq_type - Virtual Event Queue Type
> > * @IOMMU_VEVENTQ_TYPE_DEFAULT: Reserved for future use
> > + * @IOMMU_VEVENTQ_TYPE_ARM_SMMUV3: ARM SMMUv3 Virtual Event Queue
> > */
> > enum iommu_veventq_type {
> > IOMMU_VEVENTQ_TYPE_DEFAULT = 0,
> > + IOMMU_VEVENTQ_TYPE_ARM_SMMUV3 = 1,
> > +};
> > +
> > +/**
> > + * struct iommu_vevent_arm_smmuv3 - ARM SMMUv3 Virtual Event
> > + * (IOMMU_VEVENTQ_TYPE_ARM_SMMUV3)
> > + * @evt: 256-bit ARM SMMUv3 Event record, little-endian.
> > + * (Refer to "7.3 Event records" in SMMUv3 HW Spec)
> > + *
> > + * StreamID field reports a virtual device ID. To receive a virtual event for a
> > + * device, a vDEVICE must be allocated via IOMMU_VDEVICE_ALLOC.
> > + */
> > +struct iommu_vevent_arm_smmuv3 {
> > + __aligned_le64 evt[4];
> > };
>
> Nit: I think it would be more readable to add a check in the vevent
> reporting helper.
>
> diff --git a/drivers/iommu/iommufd/driver.c b/drivers/iommu/iommufd/driver.c
> index 77c34f8791ef..ccada0ada5ff 100644
> --- a/drivers/iommu/iommufd/driver.c
> +++ b/drivers/iommu/iommufd/driver.c
> @@ -86,6 +86,9 @@ int iommufd_viommu_report_event(struct iommufd_viommu
> *viommu,
> if (WARN_ON_ONCE(!data_len || !event_data))
> return -EINVAL;
>
> + if (WARN_ON_ONCE(type != IOMMU_VEVENTQ_TYPE_ARM_SMMUV3))
> + return -EINVAL;
> +
Hmm, that's a good point I think.
> down_read(&viommu->veventqs_rwsem);
>
> veventq = iommufd_viommu_find_veventq(viommu, type);
^
|
We actually have been missing a type validation entirely, so the
type could have been rejected by this function. Perhaps we should
add a static list of supported types to struct iommufd_viommu_ops
for drivers to report so that then the core could reject from the
first place during a vEVENTQ allocation.
> Or perhaps the compiler could automatically make a warning if the @type
> is not one of those values in enum iommu_veventq_type?
Just gave that a try. Mine doesn't give any warning. Not sure if
needs to be some "-W" augment though..
> Others look good to me.
Thanks for the review!
Nicolin
More information about the linux-arm-kernel
mailing list