[PATCH v3 1/7] dt-bindings: mfd: brcm,bcm59056: Convert to YAML
Artur Weber
aweber.kernel at gmail.com
Tue Feb 4 10:33:39 PST 2025
On 2.02.2025 14:27, Krzysztof Kozlowski wrote:
> On Fri, Jan 31, 2025 at 07:13:49PM +0100, Artur Weber wrote:
>> +$id: http://devicetree.org/schemas/mfd/brcm,bcm59056.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: Broadcom BCM590xx Power Management IC
>> +
>> +maintainers:
>> + - Artur Weber <aweber.kernel at gmail.com>
>> +
>> +properties:
>> + compatible:
>> + const: brcm,bcm59056
>> +
>> + reg:
>> + maxItems: 1
>> +
>> + interrupts:
>> + maxItems: 1
>> +
>> + regulators:
>> + type: object
>> + description: Container node for regulators.
>> + $ref: ../regulator/brcm,bcm59056.yaml
>
> Does this device have any other function? RTC? Charger? If not, maybe
> just put everything in one binding in regulator dir.
>
Yes, the BCM590xx PMICs have multiple other functions: power-on key,
RTC, charger/fuel gauge and some USB/audio related controls. I am
planning to extend the driver to support all of these features in the
near future; when the time comes, the DT bindings will have to be
updated as well.
>> +
>> +required:
>> + - compatible
>> + - reg
>> + - interrupts
>> +
>> +additionalProperties: false
>> +
>> +examples:
>> + - |
>> + #include <dt-bindings/interrupt-controller/arm-gic.h>
>> +
>> + i2c {
>> + #address-cells = <1>;
>> + #size-cells = <0>;
>> +
>> + pmic: bcm59056 at 8 {
>
> Node names should be generic. See also an explanation and list of
> examples (not exhaustive) in DT specification:
> https://devicetree-specification.readthedocs.io/en/latest/chapter2-devicetree-basics.html#generic-names-recommendation
>
I will fix this in the next version.
>> + compatible = "brcm,bcm59056";
>> + reg = <0x08>;
>> + interrupts = <GIC_SPI 215 IRQ_TYPE_LEVEL_HIGH>;
>> +
>> + regulators {
>> + rfldo_reg: rfldo {
>> + regulator-min-microvolt = <1200000>;
>> + regulator-max-microvolt = <3300000>;
>> + };
>> + };
>> + };
>> + };
>> diff --git a/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml b/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml
>> new file mode 100644
>> index 0000000000000000000000000000000000000000..8939004d5a3f079c05d313bed4a2f07fbc473bac
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml
>> @@ -0,0 +1,58 @@
>> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
>> +%YAML 1.2
>> +---
>> +$id: http://devicetree.org/schemas/regulator/brcm,bcm59056.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: Broadcom BCM59056 Power Management IC regulators
>> +
>> +description: |
>> + This is a part of device tree bindings for the BCM590XX family of power
>> + management ICs.
>> +
>> + See also Documentation/devicetree/bindings/mfd/brcm,bcm59056.yaml for
>> + additional information and example.
>> +
>> +maintainers:
>> + - Artur Weber <aweber.kernel at gmail.com>
>> +
>> +# The valid regulator node names for BCM59056 are:
>> +# rfldo, camldo1, camldo2, simldo1, simldo2, sdldo, sdxldo,
>> +# mmcldo1, mmcldo2, audldo, micldo, usbldo, vibldo,
>> +# csr, iosr1, iosr2, msr, sdsr1, sdsr2, vsr,
>> +# gpldo1, gpldo2, gpldo3, gpldo4, gpldo5, gpldo6,
>> +# vbus
>
> patternProperties should define this. No need to repeat schema in
> freeform text.
IMO a full list is a bit easier to read than the regexes (another
suggestion was to move the list to the description [1]), but I don't
mind dropping it. For the most part, it's a carryover from the TXT
binding.
Best regards
Artur
[1] https://lore.kernel.org/lkml/Z59BQB_cBgTDm4ie@standask-GA-A55M-S2HP/
More information about the linux-arm-kernel
mailing list