[PATCH v3 1/7] dt-bindings: mfd: brcm,bcm59056: Convert to YAML
Stanislav Jakubek
stano.jakubek at gmail.com
Sun Feb 2 01:56:16 PST 2025
On Fri, Jan 31, 2025 at 07:13:49PM +0100, Artur Weber wrote:
> Convert devicetree bindings for the Broadcom BCM59056 PMU MFD from
> TXT to YAML format. This patch does not change any functionality;
> the bindings remain the same.
>
> The bindings have been split into two parts: the MFD binding and
> a separate binding for the regulator node, to simplify the addition
> of other models later (which have different regulators).
>
> Signed-off-by: Artur Weber <aweber.kernel at gmail.com>
[snip]
> + regulators:
> + type: object
> + description: Container node for regulators.
> + $ref: ../regulator/brcm,bcm59056.yaml
Use the full path, so /schemas/regulator/brcm,bcm59056.yaml#
The description seems unnecessary, you can drop it.
> +
> +required:
> + - compatible
> + - reg
> + - interrupts
> +
> +additionalProperties: false
> +
> +examples:
> + - |
> + #include <dt-bindings/interrupt-controller/arm-gic.h>
> +
> + i2c {
> + #address-cells = <1>;
> + #size-cells = <0>;
> +
> + pmic: bcm59056 at 8 {
Node names should be generic. And drop unused label.
Should just look like this:
pmic at 8 {
> + compatible = "brcm,bcm59056";
> + reg = <0x08>;
> + interrupts = <GIC_SPI 215 IRQ_TYPE_LEVEL_HIGH>;
#include <dt-bindings/interrupt-controller/irq.h> ?
V2 seems to have it, not sure why you dropped this.
> +
> + regulators {
> + rfldo_reg: rfldo {
Unused label, drop.
> + regulator-min-microvolt = <1200000>;
> + regulator-max-microvolt = <3300000>;
> + };
> + };
> + };
> + };
> diff --git a/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml b/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml
> new file mode 100644
> index 0000000000000000000000000000000000000000..8939004d5a3f079c05d313bed4a2f07fbc473bac
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/regulator/brcm,bcm59056.yaml
> @@ -0,0 +1,58 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/regulator/brcm,bcm59056.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Broadcom BCM59056 Power Management IC regulators
> +
> +description: |
> + This is a part of device tree bindings for the BCM590XX family of power
> + management ICs.
This doesn't really say anything. Also AFAIK these are only part of BCM59056,
not the entire BCM590XX family.
Maybe say here something like:
"The BCM59056 PMIC integrates X regulators, their valid names are
lorem, ipsum, etc.
> +
> + See also Documentation/devicetree/bindings/mfd/brcm,bcm59056.yaml for
> + additional information and example.
> +
> +maintainers:
> + - Artur Weber <aweber.kernel at gmail.com>
> +
> +# The valid regulator node names for BCM59056 are:
> +# rfldo, camldo1, camldo2, simldo1, simldo2, sdldo, sdxldo,
> +# mmcldo1, mmcldo2, audldo, micldo, usbldo, vibldo,
> +# csr, iosr1, iosr2, msr, sdsr1, sdsr2, vsr,
> +# gpldo1, gpldo2, gpldo3, gpldo4, gpldo5, gpldo6,
> +# vbus
This should probably be a part of the description, not just a comment.
Could be argued to drop it since it's also described below in
patternProperties, but this is easier to read, so IMO would be better to keep.
Regards,
Stanislav
More information about the linux-arm-kernel
mailing list