[PATCH v3 2/3] dma: Introduce generic dma_addr_*crypted helpers
Gavin Shan
gshan at redhat.com
Thu Feb 27 18:09:10 PST 2025
On 2/28/25 12:41 AM, Suzuki K Poulose wrote:
> AMD SME added __sme_set/__sme_clr primitives to modify the DMA address for
> encrypted/decrypted traffic. However this doesn't fit in with other models,
> e.g., Arm CCA where the meanings are the opposite. i.e., "decrypted" traffic
> has a bit set and "encrypted" traffic has the top bit cleared.
>
> In preparation for adding the support for Arm CCA DMA conversions, convert the
> existing primitives to more generic ones that can be provided by the backends.
> i.e., add helpers to
> 1. dma_addr_encrypted - Convert a DMA address to "encrypted" [ == __sme_set() ]
> 2. dma_addr_unencrypted - Convert a DMA address to "decrypted" [ None exists today ]
> 3. dma_addr_canonical - Clear any "encryption"/"decryption" bits from DMA
> address [ SME uses __sme_clr() ] and convert to a canonical DMA address.
>
> Since the original __sme_xxx helpers come from linux/mem_encrypt.h, use that
> as the home for the new definitions and provide dummy ones when none is provided
> by the architectures.
>
> With the above, phys_to_dma_unencrypted() uses the newly added dma_addr_unencrypted()
> helper and to make it a bit more easier to read and avoid double conversion,
> provide __phys_to_dma().
>
> Suggested-by: Robin Murphy <robin.murphy at arm.com>
> Cc: Will Deacon <will at kernel.org>
> Cc: Jean-Philippe Brucker <jean-philippe at linaro.org>
> Cc: Catalin Marinas <catalin.marinas at arm.com>
> Cc: Robin Murphy <robin.murphy at arm.com>
> Cc: Steven Price <steven.price at arm.com>
> Cc: Christoph Hellwig <hch at lst.de>
> Cc: Marek Szyprowski <m.szyprowski at samsung.com>
> Cc: Tom Lendacky <thomas.lendacky at amd.com>
> Cc: Aneesh Kumar K.V <aneesh.kumar at kernel.org>
> Signed-off-by: Suzuki K Poulose <suzuki.poulose at arm.com>
> ---
> Changes since v2:
> - Rename helpers- s/dma_*crypted/dma_addr_*crypted (Robin)
> ---
> include/linux/dma-direct.h | 12 ++++++++----
> include/linux/mem_encrypt.h | 23 +++++++++++++++++++++++
> 2 files changed, 31 insertions(+), 4 deletions(-)
>
Reviewed-by: Gavin Shan <gshan at redhat.com>
More information about the linux-arm-kernel
mailing list