[PATCH net-next 3/8] net: phy: add getters for public members of struct phy_package_shared
Heiner Kallweit
hkallweit1 at gmail.com
Thu Feb 27 13:06:51 PST 2025
On 25.02.2025 10:12, Paolo Abeni wrote:
> On 2/25/25 3:01 AM, Jakub Kicinski wrote:
>> On Wed, 19 Feb 2025 22:04:47 +0100 Heiner Kallweit wrote:
>>> +struct device_node *phy_package_shared_get_node(struct phy_device *phydev);
>>> +void *phy_package_shared_get_priv(struct phy_device *phydev);
>>
>> A bit sad that none of the users can fit in a line with this naming.
>> Isn't "shared" implied by "package" here ?
>> How would you feel about phy_package_get_priv() ?
>
> FWIW I personally agree the latter would be a better name.
>
> @Heiner: could you please give that naming schema a shot here?
>
> /P
>
Sure. I'll submit a v2 with the suggested changes.
More information about the linux-arm-kernel
mailing list