[PATCH v7 16/43] drm/mediatek: mtk_hdmi: Compress of_device_id array entries
Chun-Kuang Hu
chunkuang.hu at kernel.org
Wed Feb 19 06:14:20 PST 2025
Hi, Angelo:
AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com> 於
2025年2月17日 週一 下午11:49寫道:
>
> Compress the entries found in the of_device_id array to improve
> readability of this file and to make that consistent with other
> kernel drivers.
Applied to mediatek-drm-next [1], thanks.
[1] https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-Kuang.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
> ---
> drivers/gpu/drm/mediatek/mtk_hdmi.c | 13 ++++---------
> 1 file changed, 4 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi.c b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> index 1e50b3918069..be71105ba81d 100644
> --- a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> @@ -1780,15 +1780,10 @@ static const struct mtk_hdmi_conf mtk_hdmi_conf_mt8167 = {
> };
>
> static const struct of_device_id mtk_hdmi_of_ids[] = {
> - { .compatible = "mediatek,mt2701-hdmi",
> - .data = &mtk_hdmi_conf_mt2701,
> - },
> - { .compatible = "mediatek,mt8167-hdmi",
> - .data = &mtk_hdmi_conf_mt8167,
> - },
> - { .compatible = "mediatek,mt8173-hdmi",
> - },
> - {}
> + { .compatible = "mediatek,mt2701-hdmi", .data = &mtk_hdmi_conf_mt2701 },
> + { .compatible = "mediatek,mt8167-hdmi", .data = &mtk_hdmi_conf_mt8167 },
> + { .compatible = "mediatek,mt8173-hdmi" },
> + { /* sentinel */ }
> };
> MODULE_DEVICE_TABLE(of, mtk_hdmi_of_ids);
>
> --
> 2.48.1
>
More information about the linux-arm-kernel
mailing list