[PATCH 00/11] mmc: rename mmc_retune_* to mmc_host_retune_*

Ulf Hansson ulf.hansson at linaro.org
Mon Apr 28 02:58:34 PDT 2025


On Fri, 25 Apr 2025 at 13:14, Wolfram Sang
<wsa+renesas at sang-engineering.com> wrote:
>
> As discussed previously[1], here is the next set of MMC core function
> renaming to indicate if an action is relevant for the host or for the
> card. Local build tests went fine, buildbots were happy too.
>
> [1] https://lore.kernel.org/r/CAPDyKFpsJpLre2bO9T7gsSthsta9f3JXoXTGZbjTjWVXH47gCw@mail.gmail.com
>
> Wolfram Sang (11):
>   mmc: rename mmc_retune_enable() to mmc_host_retune_enable()
>   mmc: rename mmc_retune_disable() to mmc_host_retune_disable()
>   mmc: rename mmc_retune_hold() to mmc_host_retune_hold()
>   mmc: rename mmc_retune_release() to mmc_host_retune_release()
>   mmc: rename mmc_retune() to mmc_host_retune()
>   mmc: rename mmc_retune_pause() to mmc_host_retune_pause()
>   mmc: rename mmc_retune_unpause() to mmc_host_retune_unpause()
>   mmc: rename mmc_retune_clear() to mmc_host_retune_clear()
>   mmc: rename mmc_retune_hold_now() to mmc_host_retune_hold_now()
>   mmc: rename mmc_retune_recheck() to mmc_host_retune_recheck()
>   mmc: rename mmc_retune_needed() to mmc_host_retune_needed()
>
>  drivers/mmc/core/block.c           | 16 +++++++-------
>  drivers/mmc/core/core.c            | 28 ++++++++++++------------
>  drivers/mmc/core/host.c            | 34 +++++++++++++++---------------
>  drivers/mmc/core/host.h            | 22 +++++++++----------
>  drivers/mmc/core/mmc.c             |  8 +++----
>  drivers/mmc/core/mmc_ops.c         | 12 +++++------
>  drivers/mmc/core/mmc_test.c        |  4 ++--
>  drivers/mmc/core/sdio.c            |  6 +++---
>  drivers/mmc/core/sdio_io.c         |  4 ++--
>  drivers/mmc/host/sdhci-acpi.c      |  4 ++--
>  drivers/mmc/host/sdhci-esdhc-imx.c |  6 +++---
>  drivers/mmc/host/sdhci-of-arasan.c |  2 +-
>  drivers/mmc/host/sdhci-of-at91.c   |  2 +-
>  drivers/mmc/host/sdhci-of-esdhc.c  |  2 +-
>  drivers/mmc/host/sdhci-omap.c      |  2 +-
>  drivers/mmc/host/sdhci-pci-core.c  |  6 +++---
>  drivers/mmc/host/sdhci-pltfm.c     |  2 +-
>  drivers/mmc/host/sdhci-pxav3.c     |  4 ++--
>  drivers/mmc/host/sdhci-s3c.c       |  4 ++--
>  drivers/mmc/host/sdhci-spear.c     |  2 +-
>  drivers/mmc/host/sdhci-st.c        |  2 +-
>  drivers/mmc/host/sdhci-xenon.c     |  2 +-
>  drivers/mmc/host/sdhci.c           |  2 +-
>  drivers/mmc/host/sdhci_am654.c     |  2 +-
>  drivers/mmc/host/tmio_mmc_core.c   |  4 ++--
>  include/linux/mmc/host.h           |  2 +-
>  26 files changed, 92 insertions(+), 92 deletions(-)
>

Sorry if my suggestion was unclear. I only had the MMC_CAP|CAP2_*
related functions in mind. I think we should leave the mmc_retune*
functions as is as they are not "can" functions.

mmc_host_cmd23, mmc_host_done_complete, mmc_boot_partition_access,
mmc_host_uhs. All in drivers/mmc/core/host.h

According to your earlier renaming series, we should rename these function too:
mmc_host_can_cmd23, mmc_host_can_done_complete,
mmc_host_can_boot_partition, mmc_host_can_uhs

Does this make sense to you?

Kind regards
Uffe



More information about the linux-arm-kernel mailing list