[PATCH v3 3/6] iio: adc: ad4695: use IIO_DECLARE_DMA_BUFFER_WITH_TS
Jonathan Cameron
jic23 at kernel.org
Sat Apr 26 04:24:22 PDT 2025
On Fri, 25 Apr 2025 16:08:45 -0500
David Lechner <dlechner at baylibre.com> wrote:
> Use IIO_DECLARE_DMA_BUFFER_WITH_TS() to declare the buffer that gets
> used with iio_push_to_buffers_with_ts(). This makes the code a bit
> easier to read and understand.
>
> Signed-off-by: David Lechner <dlechner at baylibre.com>
> ---
> drivers/iio/adc/ad4695.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/iio/adc/ad4695.c b/drivers/iio/adc/ad4695.c
> index 0c633d43e480d5404074e9fa35f1d330b448f0a2..992abf6c63b51dee222caf624e172455fb9b9900 100644
> --- a/drivers/iio/adc/ad4695.c
> +++ b/drivers/iio/adc/ad4695.c
> @@ -160,8 +160,7 @@ struct ad4695_state {
> struct spi_transfer buf_read_xfer[AD4695_MAX_CHANNELS * 2 + 3];
> struct spi_message buf_read_msg;
> /* Raw conversion data received. */
> - u16 buf[ALIGN((AD4695_MAX_CHANNELS + 1) * sizeof(u16),
> - sizeof(s64)) + sizeof(s64)] __aligned(IIO_DMA_MINALIGN);
> + IIO_DECLARE_DMA_BUFFER_WITH_TS(u16, buf, AD4695_MAX_CHANNELS + 1);
As a follow up, maybe we can rename that AD4695_MAX_CHANNELS to
AD4695_MAX_ADC_CHANNELS so I don't wonder why there is a + 1?
> u16 raw_data;
> /* Commands to send for single conversion. */
> u16 cnv_cmd;
>
More information about the linux-arm-kernel
mailing list