[cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field modify
Keller, Jacob E
jacob.e.keller at intel.com
Wed Apr 23 09:54:49 PDT 2025
> -----Original Message-----
> From: cocci-request at inria.fr <cocci-request at inria.fr> On Behalf Of Russell King
> (Oracle)
> Sent: Thursday, April 17, 2025 11:11 AM
> To: Luo Jie <quic_luoj at quicinc.com>
> Cc: Yury Norov <yury.norov at gmail.com>; Rasmus Villemoes
> <linux at rasmusvillemoes.dk>; Julia Lawall <Julia.Lawall at inria.fr>; Nicolas Palix
> <nicolas.palix at imag.fr>; Catalin Marinas <catalin.marinas at arm.com>; Will
> Deacon <will at kernel.org>; Marc Zyngier <maz at kernel.org>; Oliver Upton
> <oliver.upton at linux.dev>; Joey Gouly <joey.gouly at arm.com>; Suzuki K Poulose
> <suzuki.poulose at arm.com>; Zenghui Yu <yuzenghui at huawei.com>; linux-
> kernel at vger.kernel.org; cocci at inria.fr; linux-arm-kernel at lists.infradead.org;
> kvmarm at lists.linux.dev; andrew at lunn.ch; quic_kkumarcs at quicinc.com;
> quic_linchen at quicinc.com; quic_leiwei at quicinc.com;
> quic_suruchia at quicinc.com; quic_pavir at quicinc.com
> Subject: Re: [cocci] [PATCH v3 3/6] arm64: tlb: Convert the opencoded field
> modify
>
> On Thu, Apr 17, 2025 at 06:47:10PM +0800, Luo Jie wrote:
> > Replaced below code with the wrapper FIELD_MODIFY(MASK, ®, val)
> > - reg &= ~MASK;
> > - reg |= FIELD_PREP(MASK, val);
> > The semantic patch that makes this change is available
> > in scripts/coccinelle/misc/field_modify.cocci.
> >
> > More information about semantic patching is available at
> > https://coccinelle.gitlabpages.inria.fr/website
> >
> > Signed-off-by: Luo Jie <quic_luoj at quicinc.com>
> > ---
> > arch/arm64/include/asm/tlbflush.h | 3 +--
> > 1 file changed, 1 insertion(+), 2 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/tlbflush.h
> b/arch/arm64/include/asm/tlbflush.h
> > index eba1a98657f1..0d250ef4161c 100644
> > --- a/arch/arm64/include/asm/tlbflush.h
> > +++ b/arch/arm64/include/asm/tlbflush.h
> > @@ -112,8 +112,7 @@ static inline unsigned long get_trans_granule(void)
> > level >= 0 && level <= 3) { \
> > u64 ttl = level & 3; \
> > ttl |= get_trans_granule() << 2; \
> > - arg &= ~TLBI_TTL_MASK; \
> > - arg |= FIELD_PREP(TLBI_TTL_MASK, ttl); \
> > + FIELD_MODIFY(TLBI_TTL_MASK, &arg, ttl); \
>
> This could equally be:
> arg = u64_replace_bits(arg, ttl, TLBI_TTL_MASK);
>
> which already exists, so doesn't require a new macro to be introduced.
>
I had been looking for something like this the other day but was grepping for "FIELD_REPLACE" and similar which didn't find things.. Neat to know it exists already :D
> --
> RMK's Patch system: https://www.armlinux.org.uk/developer/patches/
> FTTP is here! 80Mbps down 10Mbps up. Decent connectivity at last!
More information about the linux-arm-kernel
mailing list