[PATCH v3 08/12] arm64: Move esr_comment() to <asm/esr.h>
Will Deacon
will at kernel.org
Mon May 13 07:57:02 PDT 2024
On Fri, May 10, 2024 at 12:26:37PM +0100, Pierre-Clément Tosi wrote:
> As it is already defined twice and is about to be needed for kCFI error
> detection, move esr_comment() to a header for re-use, with a clearer
> name.
esr_comment() is defined twice? I only see one macro definition, but yes,
it's open-coded in nvhe_hyp_panic_handler too.
> Signed-off-by: Pierre-Clément Tosi <ptosi at google.com>
> ---
> arch/arm64/include/asm/esr.h | 5 +++++
> arch/arm64/kernel/debug-monitors.c | 4 +---
> arch/arm64/kernel/traps.c | 8 +++-----
> arch/arm64/kvm/handle_exit.c | 2 +-
> 4 files changed, 10 insertions(+), 9 deletions(-)
>
> diff --git a/arch/arm64/include/asm/esr.h b/arch/arm64/include/asm/esr.h
> index 81606bf7d5ac..2bcf216be376 100644
> --- a/arch/arm64/include/asm/esr.h
> +++ b/arch/arm64/include/asm/esr.h
> @@ -379,6 +379,11 @@
> #ifndef __ASSEMBLY__
> #include <asm/types.h>
>
> +static inline unsigned long esr_brk_comment(unsigned long esr)
> +{
> + return esr & ESR_ELx_BRK64_ISS_COMMENT_MASK;
> +}
> +
> static inline bool esr_is_data_abort(unsigned long esr)
> {
> const unsigned long ec = ESR_ELx_EC(esr);
> diff --git a/arch/arm64/kernel/debug-monitors.c b/arch/arm64/kernel/debug-monitors.c
> index 64f2ecbdfe5c..024a7b245056 100644
> --- a/arch/arm64/kernel/debug-monitors.c
> +++ b/arch/arm64/kernel/debug-monitors.c
> @@ -312,9 +312,7 @@ static int call_break_hook(struct pt_regs *regs, unsigned long esr)
> * entirely not preemptible, and we can use rcu list safely here.
> */
> list_for_each_entry_rcu(hook, list, node) {
> - unsigned long comment = esr & ESR_ELx_BRK64_ISS_COMMENT_MASK;
> -
> - if ((comment & ~hook->mask) == hook->imm)
> + if ((esr_brk_comment(esr) & ~hook->mask) == hook->imm)
> fn = hook->fn;
> }
>
> diff --git a/arch/arm64/kernel/traps.c b/arch/arm64/kernel/traps.c
> index 215e6d7f2df8..2652247032ae 100644
> --- a/arch/arm64/kernel/traps.c
> +++ b/arch/arm64/kernel/traps.c
> @@ -1105,8 +1105,6 @@ static struct break_hook ubsan_break_hook = {
> };
> #endif
>
> -#define esr_comment(esr) ((esr) & ESR_ELx_BRK64_ISS_COMMENT_MASK)
> -
> /*
> * Initial handler for AArch64 BRK exceptions
> * This handler only used until debug_traps_init().
> @@ -1115,15 +1113,15 @@ int __init early_brk64(unsigned long addr, unsigned long esr,
> struct pt_regs *regs)
> {
> #ifdef CONFIG_CFI_CLANG
> - if ((esr_comment(esr) & ~CFI_BRK_IMM_MASK) == CFI_BRK_IMM_BASE)
> + if ((esr_brk_comment(esr) & ~CFI_BRK_IMM_MASK) == CFI_BRK_IMM_BASE)
> return cfi_handler(regs, esr) != DBG_HOOK_HANDLED;
> #endif
> #ifdef CONFIG_KASAN_SW_TAGS
> - if ((esr_comment(esr) & ~KASAN_BRK_MASK) == KASAN_BRK_IMM)
> + if ((esr_brk_comment(esr) & ~KASAN_BRK_MASK) == KASAN_BRK_IMM)
> return kasan_handler(regs, esr) != DBG_HOOK_HANDLED;
> #endif
> #ifdef CONFIG_UBSAN_TRAP
> - if ((esr_comment(esr) & ~UBSAN_BRK_MASK) == UBSAN_BRK_IMM)
> + if ((esr_brk_comment(esr) & ~UBSAN_BRK_MASK) == UBSAN_BRK_IMM)
> return ubsan_handler(regs, esr) != DBG_HOOK_HANDLED;
> #endif
> return bug_handler(regs, esr) != DBG_HOOK_HANDLED;
> diff --git a/arch/arm64/kvm/handle_exit.c b/arch/arm64/kvm/handle_exit.c
> index 617ae6dea5d5..0bcafb3179d6 100644
> --- a/arch/arm64/kvm/handle_exit.c
> +++ b/arch/arm64/kvm/handle_exit.c
> @@ -395,7 +395,7 @@ void __noreturn __cold nvhe_hyp_panic_handler(u64 esr, u64 spsr,
> if (mode != PSR_MODE_EL2t && mode != PSR_MODE_EL2h) {
> kvm_err("Invalid host exception to nVHE hyp!\n");
> } else if (ESR_ELx_EC(esr) == ESR_ELx_EC_BRK64 &&
> - (esr & ESR_ELx_BRK64_ISS_COMMENT_MASK) == BUG_BRK_IMM) {
> + esr_brk_comment(esr) == BUG_BRK_IMM) {
> const char *file = NULL;
> unsigned int line = 0;
With the commit message tweaked:
Acked-by: Will Deacon <will at kernel.org>
Will
More information about the linux-arm-kernel
mailing list