[PATCH v5 10/27] iommu/arm-smmu-v3: Move the CD generation for SVA into a function

Nicolin Chen nicolinc at nvidia.com
Fri Mar 15 22:19:45 PDT 2024


On Mon, Mar 04, 2024 at 07:43:58PM -0400, Jason Gunthorpe wrote:
> @@ -1070,8 +1062,7 @@ static u8 arm_smmu_entry_qword_diff(struct arm_smmu_entry_writer *writer,
>  		 * Each bit indicates that a used bit in a qword needs to be
>  		 * changed after unused_update is applied.
>  		 */
> -		if ((unused_update[i] & target_used[i]) !=
> -		    (target[i] & target_used[i]))
> +		if ((unused_update[i] & target_used[i]) != target[i])
>  			used_qword_diff |= 1 << i;

Would you mind elaborating why we drop this "& target_used[i]"
against the target[i] on the right?

Thanks
Nicolin



More information about the linux-arm-kernel mailing list