>> + clk = devm_clk_get_optional_enabled(dev, "lpo");
>> + if (IS_ERR(clk))
>> + if (clk) {
>
> These two lines looks really confusing. Shouldn't it be just a single
> "if (!IS_ERR(clk)) {" line instead?
Thanks for the correction... I forgot to organize this...
---
Best Regards
Jacobe