[PATCH] irqchip/irq-bcm7038-l1: Prefer struct_size over open coded arithmetic
Gustavo A. R. Silva
gustavo at embeddedor.com
Fri Feb 9 10:40:36 PST 2024
On 2/9/24 12:31, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the cpu variable is a pointer to "struct bcm7038_l1_cpu" and this
> structure ends in a flexible array:
>
> struct bcm7038_l1_cpu {
> void __iomem *map_base;
> u32 mask_cache[];
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> kzalloc() function.
>
> This way, the code is more readable and more safer.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162 [2]
>
> Signed-off-by: Erick Archer <erick.archer at gmx.com>
LGTM:
Reviewed-by: Gustavo A. R. Silva <gustavoars at kernel.org>
Thanks
--
Gustavo
> ---
> drivers/irqchip/irq-bcm7038-l1.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/irqchip/irq-bcm7038-l1.c b/drivers/irqchip/irq-bcm7038-l1.c
> index 24ca1d656adc..36e71af054e9 100644
> --- a/drivers/irqchip/irq-bcm7038-l1.c
> +++ b/drivers/irqchip/irq-bcm7038-l1.c
> @@ -249,7 +249,7 @@ static int __init bcm7038_l1_init_one(struct device_node *dn,
> return -EINVAL;
> }
>
> - cpu = intc->cpus[idx] = kzalloc(sizeof(*cpu) + n_words * sizeof(u32),
> + cpu = intc->cpus[idx] = kzalloc(struct_size(cpu, mask_cache, n_words),
> GFP_KERNEL);
> if (!cpu)
> return -ENOMEM;
> --
> 2.25.1
>
More information about the linux-arm-kernel
mailing list