[PATCH v2 12/15] drm/mediatek: mtk_hdmi: Split driver and add common probe function
CK Hu (胡俊光)
ck.hu at mediatek.com
Sun Dec 8 23:51:30 PST 2024
Hi, Angelo:
On Thu, 2024-12-05 at 12:45 +0100, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
>
>
> In preparation for adding a new driver for the HDMI TX v2 IP,
> split out the functions that will be common between the already
> present mtk_hdmi (v1) driver and the new one.
>
> Since the probe flow for both drivers is 90% similar, add a common
> probe function that will be called from each driver's .probe()
> callback, avoiding lots of code duplication.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
> ---
[snip]
> +struct mtk_hdmi *mtk_hdmi_common_probe(struct platform_device *pdev)
> +{
> + const struct mtk_hdmi_ver_conf *ver_conf;
> + struct device *dev = &pdev->dev;
> + struct mtk_hdmi *hdmi;
> + int ret;
> +
> + hdmi = devm_kzalloc(&pdev->dev, sizeof(*hdmi), GFP_KERNEL);
> + if (!hdmi)
> + return ERR_PTR(-ENOMEM);
> +
> + hdmi->dev = dev;
> + hdmi->conf = of_device_get_match_data(dev);
> + ver_conf = hdmi->conf->ver_conf;
> +
> + hdmi->clk = devm_kcalloc(dev, ver_conf->num_clocks, sizeof(*hdmi->clk), GFP_KERNEL);
> + if (!hdmi->clk)
> + return ERR_PTR(-ENOMEM);
> +
> + hdmi->phy = devm_phy_get(dev, "hdmi");
> + if (IS_ERR(hdmi->phy))
> + return dev_err_cast_probe(dev, hdmi->phy, "Failed to get HDMI PHY\n");
> +
> + ret = mtk_hdmi_dt_parse_pdata(hdmi, pdev, ver_conf->mtk_hdmi_clock_names,
> + ver_conf->num_clocks);
> + if (ret)
> + return ERR_PTR(ret);
> +
> + platform_set_drvdata(pdev, hdmi);
> +
> + ret = mtk_hdmi_register_audio_driver(dev);
> + if (ret)
> + return dev_err_ptr_probe(dev, ret, "Cannot register HDMI Audio driver\n");
> +
> + hdmi->bridge.funcs = ver_conf->bridge_funcs;
> + hdmi->bridge.ops = DRM_BRIDGE_OP_DETECT | DRM_BRIDGE_OP_EDID | DRM_BRIDGE_OP_HPD;
> + hdmi->bridge.type = DRM_MODE_CONNECTOR_HDMIA;
> + hdmi->bridge.of_node = pdev->dev.of_node;
> +
> + ret = devm_drm_bridge_add(dev, &hdmi->bridge);
You change drm_bridge_add() to devm_drm_bridge_add(). If this is necessary, separate this to a refinement patch.
Regards,
CK
> + if (ret)
> + return dev_err_ptr_probe(dev, ret, "Failed to add bridge\n");
> +
> + return hdmi;
> +}
> +
More information about the linux-arm-kernel
mailing list