[PATCH RESEND v2 2/2] pwm: Add Nuvoton MA35D1 PWM controller support

Chi-Wen Weng cwweng.linux at gmail.com
Thu Dec 5 21:58:45 PST 2024


Hi Uwe,

Thanks for your comments.


On 2024/11/21 上午 06:03, Uwe Kleine-König wrote:
> hello,
>
> On Wed, Nov 20, 2024 at 11:49:48AM -0500, Trevor Gamblin wrote:
>> On 2024-10-24 06:43, Chi-Wen Weng wrote:
>>> +#include <linux/mod_devicetable.h>
>>> +#include <linux/module.h>
>>> +#include <linux/platform_device.h>
>>> +#include <linux/pwm.h>
>>> +#include <linux/io.h>
>>> +#include <linux/clk.h>
>>> +#include <linux/math64.h>
>> These should be organized alphabetically.
>>> +
>>> +/* The following are registers for PWM controller */
>>> +#define REG_PWM_CTL0            (0x00)
>>> +#define REG_PWM_CNTEN           (0x20)
>>> +#define REG_PWM_PERIOD0         (0x30)
>>> +#define REG_PWM_CMPDAT0         (0x50)
>>> +#define REG_PWM_WGCTL0          (0xB0)
>>> +#define REG_PWM_POLCTL          (0xD4)
>>> +#define REG_PWM_POEN            (0xD8)
>> These too, I think - it will make it more readable for others.
> Keeping the registers in address order is the usual thing to do, so
> please keep the order of these.
>
> Otherwise I agree to Trevor's comments. Thanks for taking the time to
> look at this patch.
>
> Best regards
> Uwe


I will keep the registers in address order.

Otherwise I will modify per Trevor's suggestions .


Thanks.

Chi-Wen Weng




More information about the linux-arm-kernel mailing list