[PATCH v13 03/24] virt: gunyah: Add hypercalls to identify Gunyah
Alex Elder
elder at linaro.org
Mon Jun 5 12:47:31 PDT 2023
On 5/9/23 3:47 PM, Elliot Berman wrote:
> Add hypercalls to identify when Linux is running a virtual machine under
> Gunyah.
>
> There are two calls to help identify Gunyah:
>
> 1. gh_hypercall_get_uid() returns a UID when running under a Gunyah
> hypervisor.
> 2. gh_hypercall_hyp_identify() returns build information and a set of
> feature flags that are supported by Gunyah.
>
> Reviewed-by: Srinivas Kandagatla <srinivas.kandagatla at linaro.org>
> Signed-off-by: Elliot Berman <quic_eberman at quicinc.com>
I have a suggestion below. But whether or not you choose to
incorporate it:
Reviewed-by: Alex Elder <elder at linaro.org>
> ---
> arch/arm64/Kbuild | 1 +
> arch/arm64/gunyah/Makefile | 3 ++
> arch/arm64/gunyah/gunyah_hypercall.c | 56 ++++++++++++++++++++++++++++
> drivers/virt/Kconfig | 2 +
> drivers/virt/gunyah/Kconfig | 13 +++++++
> include/linux/gunyah.h | 31 +++++++++++++++
> 6 files changed, 106 insertions(+)
> create mode 100644 arch/arm64/gunyah/Makefile
> create mode 100644 arch/arm64/gunyah/gunyah_hypercall.c
> create mode 100644 drivers/virt/gunyah/Kconfig
>
> diff --git a/arch/arm64/Kbuild b/arch/arm64/Kbuild
> index 5bfbf7d79c99..e4847ba0e3c9 100644
> --- a/arch/arm64/Kbuild
> +++ b/arch/arm64/Kbuild
> @@ -3,6 +3,7 @@ obj-y += kernel/ mm/ net/
> obj-$(CONFIG_KVM) += kvm/
> obj-$(CONFIG_XEN) += xen/
> obj-$(subst m,y,$(CONFIG_HYPERV)) += hyperv/
> +obj-$(CONFIG_GUNYAH) += gunyah/
> obj-$(CONFIG_CRYPTO) += crypto/
>
> # for cleaning
> diff --git a/arch/arm64/gunyah/Makefile b/arch/arm64/gunyah/Makefile
> new file mode 100644
> index 000000000000..84f1e38cafb1
> --- /dev/null
> +++ b/arch/arm64/gunyah/Makefile
> @@ -0,0 +1,3 @@
> +# SPDX-License-Identifier: GPL-2.0
> +
> +obj-$(CONFIG_GUNYAH) += gunyah_hypercall.o
> diff --git a/arch/arm64/gunyah/gunyah_hypercall.c b/arch/arm64/gunyah/gunyah_hypercall.c
> new file mode 100644
> index 000000000000..2166d5dab869
> --- /dev/null
> +++ b/arch/arm64/gunyah/gunyah_hypercall.c
> @@ -0,0 +1,56 @@
> +// SPDX-License-Identifier: GPL-2.0-only
> +/*
> + * Copyright (c) 2022-2023 Qualcomm Innovation Center, Inc. All rights reserved.
> + */
> +
> +#include <linux/arm-smccc.h>
> +#include <linux/module.h>
> +#include <linux/gunyah.h>
> +#include <linux/uuid.h>
> +
> +/* {c1d58fcd-a453-5fdb-9265-ce36673d5f14} */
> +static const uuid_t GUNYAH_UUID =
> + UUID_INIT(0xc1d58fcd, 0xa453, 0x5fdb, 0x92, 0x65, 0xce, 0x36, 0x67, 0x3d, 0x5f, 0x14);
> +
> +bool arch_is_gh_guest(void)
> +{
> + struct arm_smccc_res res;
> + uuid_t uuid;
> +
> + arm_smccc_1_1_hvc(ARM_SMCCC_VENDOR_HYP_CALL_UID_FUNC_ID, &res);
> +
> + ((u32 *)&uuid.b[0])[0] = lower_32_bits(res.a0);
> + ((u32 *)&uuid.b[0])[1] = lower_32_bits(res.a1);
> + ((u32 *)&uuid.b[0])[2] = lower_32_bits(res.a2);
> + ((u32 *)&uuid.b[0])[3] = lower_32_bits(res.a3);
I think I'd rather see this more like:
u32 *up = (u32 *)&uuid.b;
/* The lower bytes of the four result fields encode the UUID */
*up++ = lower_32_bits(res.a0);
*up++ = lower_32_bits(res.a1);
*up++ = lower_32_bits(res.a2);
*up = lower_32_bits(res.a3);
Basically I think casting the assigned-to value makes things
harder to read. So doing that cast just once seems simpler.
But it's not a big deal.
> +
> + return uuid_equal(&uuid, &GUNYAH_UUID);
> +}
> +EXPORT_SYMBOL_GPL(arch_is_gh_guest);
. . .
More information about the linux-arm-kernel
mailing list