[PATCH 5/7] PCI: tegra: Convert to devm_of_phy_optional_get()
Bjorn Helgaas
helgaas at kernel.org
Mon Jan 23 10:17:25 PST 2023
On Wed, Jan 18, 2023 at 11:15:18AM +0100, Geert Uytterhoeven wrote:
> Use the new devm_of_phy_optional_get() helper instead of open-coding the
> same operation.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas at glider.be>
Thanks!
Acked-by: Bjorn Helgaas <bhelgaas at google.com>
Let me know if you want me to apply; otherwise I'll assume you will
merge along with the [1/7] patch.
> ---
> drivers/pci/controller/pci-tegra.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/pci/controller/pci-tegra.c b/drivers/pci/controller/pci-tegra.c
> index 929f9363e94bec71..5b8907c663e516ad 100644
> --- a/drivers/pci/controller/pci-tegra.c
> +++ b/drivers/pci/controller/pci-tegra.c
> @@ -1330,12 +1330,9 @@ static struct phy *devm_of_phy_optional_get_index(struct device *dev,
> if (!name)
> return ERR_PTR(-ENOMEM);
>
> - phy = devm_of_phy_get(dev, np, name);
> + phy = devm_of_phy_optional_get(dev, np, name);
> kfree(name);
>
> - if (PTR_ERR(phy) == -ENODEV)
> - phy = NULL;
> -
> return phy;
> }
>
> --
> 2.34.1
>
>
> _______________________________________________
> linux-arm-kernel mailing list
> linux-arm-kernel at lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
More information about the linux-arm-kernel
mailing list