[PATCH v5 0/3] Add MT8195 HDMI phy support

Guillaume Ranquet granquet at baylibre.com
Mon Nov 28 08:17:35 PST 2022


Add support for HDMI phy on MT8195.

This is based on top of next-20221128

To: Chunfeng Yun <chunfeng.yun at mediatek.com>
To: Kishon Vijay Abraham I <kishon at ti.com>
To: Vinod Koul <vkoul at kernel.org>
To: Rob Herring <robh+dt at kernel.org>
To: Krzysztof Kozlowski <krzysztof.kozlowski+dt at linaro.org>
To: Matthias Brugger <matthias.bgg at gmail.com>
To: Chun-Kuang Hu <chunkuang.hu at kernel.org>
To: Philipp Zabel <p.zabel at pengutronix.de>
To: David Airlie <airlied at gmail.com>
To: Daniel Vetter <daniel at ffwll.ch>
To: CK Hu <ck.hu at mediatek.com>
To: Jitao shi <jitao.shi at mediatek.com>
Cc: linux-arm-kernel at lists.infradead.org
Cc: linux-mediatek at lists.infradead.org
Cc: linux-phy at lists.infradead.org
Cc: devicetree at vger.kernel.org
Cc: linux-kernel at vger.kernel.org
Cc: Krzysztof Kozlowski <krzysztof.kozlowski at linaro.org>
Cc: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
Cc: mac.shen at mediatek.com
CC: stuart.lee at mediatek.com
Signed-off-by: Guillaume Ranquet <granquet at baylibre.com>
---
Changes in v5:
- Fix compilation errors on 32 bits platform with no support for __udivdi3.
    Compile tested on mips with gcc-12
- Link to v4: https://lore.kernel.org/r/20220919-v4-0-bdc21e1307e9@baylibre.com

Changes in v4:
- Dedicated series for HDMI phy support (without the drm/ related
  changes)
- Removed useless variable initializations in phy driver
- Link to v3: https://lore.kernel.org/r/20220919-v3-0-a803f2660127@baylibre.com

Changes in v3:
- phy: Grouped register and bit definition together to add clarity
- dt-bindings: Addressed comments
- Link to v2: https://lore.kernel.org/r/20220919-v2-0-8419dcf4f09d@baylibre.com

Changes in v2:
- Removed syscon requirement from the hdmi node
- Use as much as possible bit FIELD_PREP/FIELD_GET macros across all the
  patches
- Make cec optional dynamically instead of hardcoded with a flag
- Renamed hdmi variants to v1 (legacy) and v2 (mt8195) while waiting for
  a better name
- Rework hdmi v2 code to use a connector (same as v1)
- Remove "magic" 0x43 addr special handling in hdmi ddc code
- Link to v1: https://lore.kernel.org/r/20220919-v1-0-4844816c9808@baylibre.com

---
Guillaume Ranquet (3):
      dt-bindings: phy: mediatek: hdmi-phy: Add mt8195 compatible
      phy: phy-mtk-hdmi: Add generic phy configure callback
      phy: mediatek: add support for phy-mtk-hdmi-mt8195

 .../devicetree/bindings/phy/mediatek,hdmi-phy.yaml |   1 +
 drivers/phy/mediatek/Makefile                      |   1 +
 drivers/phy/mediatek/phy-mtk-hdmi-mt8195.c         | 527 +++++++++++++++++++++
 drivers/phy/mediatek/phy-mtk-hdmi-mt8195.h         | 111 +++++
 drivers/phy/mediatek/phy-mtk-hdmi.c                |  15 +
 drivers/phy/mediatek/phy-mtk-hdmi.h                |   2 +
 6 files changed, 657 insertions(+)
---
base-commit: 15f2f20ccbf2d04cb14e3e7635aa0447208c71e7
change-id: 20220919-hdmi_mtk

Best regards,
-- 
Guillaume Ranquet <granquet at baylibre.com>



More information about the linux-arm-kernel mailing list